Compilation of Windows 10 Methods, Steps and Solutions


Good to know.

So far there have not been any issues but obviously, it is early yet.

It is interesting that all the computers attached to the network became visible once I followed the “disable” instructions. Prior to that, ever since I had upgraded, there was almost no point at which computers (either real computers or WD drives, etc.) could be seen in Windows File Manager. At first I had just upgraded. [in general, I have enjoyed using Windows 10, much like Windows 7. I disliked Windows 8]. But to continue, after a few issues with Network drives, Network issues and Bluetooth issues, I decided to do a “clean” install. The outcome of this was that it worked for about a day (i.e. I could see computer drives on the Computer section of Windows File Manager) then it stopped and has not worked since, regardless of various suggestions tried. The Bluetooth and other Network issues (wireless) cleared up and a Microsoft technician walked me through a Drive Mapping that worked. You could not browse to find the drives but if you knew the actual locations (i.e. \server\share <file:///\server\share> …), you could create them. It implied that Windows 10 knew the network drives (WD My Cloud) did exist but you could not see them in Windows File Manager. I used this work around until I saw your post. I have tried it and so-far so-good.

If anything strange happens, I will keep you apprised.



Updated option 1 under method 6 to include changing SMB2 to SMB3.


Would you happen to know where to find the smb.conf file in Windows 10?

That seems to be the other potential conflict. WORKGROUP needs to be set to the same. Technically all the places to look say “STATISTICS” (my workgroup) but sometimes a file does not have the correct name.

It is one of the instances of why computers can be so annoying at times. A simple change of one statement will allow everything to work well. You just have to know a) which statement and b) where it is located.



There is a smb.conf file in the same folder, /root/etc/samba/, as the smb-global.conf file. I take it setting the Workgroup Name in the Dashboard > Settings > Network > Network Workgroup > Workgroup Name isn’t working? I assume the firmware would be (or should be) updating the workgroup and realm setting from the smb.conf file.

I’ve been in the computing field for more than 4 decades and I can’t recall when I’ve seen anything as bizarre as this Windows 10/Network issue.

But, the good news for me is that my Network devices (mostly) are once again being shown in Windows Explorer; one new one every 15 minutes! what that tells me is that is more involved in Network Discovery than SMB functions. The changes I made were to eliminate Homegroups. Then I changed all the workgroup names back to WORKGROUP. Finally, I turned OFF [Public Folder Sharing].

What does this mean? I have no friggin’ clue. But I’m pretty sure it’s not absolutely related to Samba and SMB1,2 & 3. Why? Because I didn’t modify/stop or start any SMB services. At the present moment I have almost all network devices showing again except for the WDMyCloud.

News at 11, or 12 or next week.


1 Like

Your Win 10 issue may not be related to SMB but for some reason mine is. The minute I change SMB, either in the My Cloud or Windows 10, to either SMB 1 or SMB 3 suddenly my Windows 10 PC starts picking up the My Cloud under Computer in Windows File Explorer.

I twigged to the SMB2 issue based on reading posts elsewhere complaining about Windows 10 not being able to see other manufacturer’s NAS units post November Win 10 update and their talking about SMB. It also appears, based on one post from a user using the v2.x My Cloud firmware that has a SMB option on the Dashboard that they changed it to SMB1 and their Windows 10 started to pick up the My Cloud.

Ah, the weirdness continues. At least I think we all agree; it is a Windows 10 issue. :grinning:


A potential fix may be forthcoming from Microsoft based on this recent posting made to a thread stared elsewhere: Cannot connect to CIFS / SMB / Samba Network Shares & Shared Folders in Windows 10 after update 1511/10586. Hat tip to Morden2004 who posted this to another thread.

I wanted to let you know that we were able to identify the issue and ultimately find out that a fix was already in the works and checked into our latest builds. I tested on build 11103 in my environment and confirmed that the machine is able to find other devices on the networking using both NetBIOS and WSD when performing Network Discovery.

I see that 11102 is available for WIP so it should be contained within that build image as well.

Please do some testing and let me know the results.


Adam Rudell | Windows Networking Beta | Microsoft Corporation

Proposed as answer by ARUDELLMicrosoft employee Monday, January 25, 2016 5:40 PM
Edited by ARUDELLMicrosoft employee Monday, January 25, 2016 5:42 PM
Monday, January 25, 2016 5:40 PM

1 Like

Windows 10 users who still have the missing [Network] devices and are at the following Windows 10 level:

Version: 1511
Build: 10586.71

please report back as I’m trying to figure out just where the change was incorporated.
At the moment the [Network] devices do show correctly in build 10586.71 as far as I know even though the Windows 10 forum is silent on this.
All 3 of my Windows 10 computers are now showing the devices in Windows Explorer.


On my one Windows 10 PC:

Version 1511
Build 10586.71

My Cloud does not show under Network (or Computer) even after hitting the refresh button.

my product id is 00326-10000-00000-AA339
it is a windows 10 home that I just upgraded my win8.1 home to
I do not see my vdmycloud as computer.or under network

I can see the vdmycloud on my other 3 windows 10 pro computers

I found my version to be 1511 and build to be 10586.71 on this home edition.

I have three computers running windows 10 Pro Version 1511 Build 10586.71. Two desktops and a laptop. Both desktops show the My Cloud and other devices under the network. The laptop does not show the My Cloud.


Interesting results. This would seem to indicate that the issue of missing network devices is not as simple as they thought in the Windows 10 forum. The results over there with testing the latest beta build with, it was stated, a fix for this issue is mixed just like our results here.

One way to quickly test the SMB results in your network is to issue the following command in a command window;

net view /all

My results for that are the same as in Windows Explorer; all the network computers are there. I guess the problem is still not fully understood and they are still shooting in the dark.


The other day I did the net view /all on my laptop and it did not show any connections. When I run net view /all on the two desktop systems. They showed all of the devices
on the network. But today I did the net view /all on my laptop and now it showed all of the network connections. I then opened the file explorer and clicked on network and all of the devices are displayed. Strange.


Same experience here. One day no devices in [Network] and next day they were there. Odd.


Net view /all on my Win 10 box yields just the Win 10 PC and a Win 7 PC, no My Cloud. Been like that since the November update.

Good news for Windows 10 users.

Microsoft have finally started a Change log for each Windows 10 update (give you a synopsis of the changes included in each update) and they have created a new web site Windows 10 Update History

As far as the current issue of the WDMyCloud(s) not showing in the [Network] list, this has not yet been addressed in a firm release. However, there are beta tests ongoing that we hope will finally fix that bug.

I believe I have found a work-around for this bug but it requires some knowledge of Windows networking, running commands at the CMD prompt, and having a Linux device on your network (computer or router). I am willing to communicate this work-around to interested Windows 10 users who meet the above requirements.


the wdmyclud is still showing in network on my laptop that have missed it for month. So something must have happened.

Added the following subsection to the initial post that may help those who have routers/gateways that support Samba file sharing.

If router/gateway supports Master Browser:

If one has a router/gateway that supports enabling the Master Browser option, enable that option on the router. Note: Generally one has to enable USB/FTP sharing or the Samba file server on the router/gateway in order to be able to enable Master Browser on that same router/gateway.

Once Master Browser has been enabled on the router/gateway, reboot the Windows 10 computer and recheck if the My Cloud shows up under Computer.

Typically the option to enable Master Browser is located under the Samba settings on those router/gateway units that support Samba file sharing.

Microsoft has released KB 3140743 on March 1, 2016.

Cumulative Update for Windows 10 Version 1511

Among the fixes is the following:

“Improved reliability in numerous areas, including OS and Windows Update installation, startup, installing and configuring Windows for the first time, authentication, resuming from hibernation, shutdown, kernel, Start menu, storage, Windows Hello, display modes, Miracast, AppLocker, Internet Explorer 11, Microsoft Edge browser, network connectivity and discovery, and File Explorer.

Also released on March 1, 2016 was KB 3139907.

Servicing stack update for Windows 10 Version 1511

Edit to add: So far it appears this update fixed the My Cloud not showing up under Computer issue (knock on wood). Started a new thread where I posted images showing pre/post update. People can use that thread to post their experiences with the KB 3140743 update rather than clutter up this thread. Will update OP post with new information if others report success with this update.