Compatible USB HDD Drives

Would everyone like to report in a reply which brand and type external HDD drives

that works on the USB port and which do not.

This would be easy for those who have a need to purchase a drive,

so they definitely buy one that is compatible with the system.

I can already tell that the Seagate Expansion 4TB does not work for me.

I have a Lacie drive USB 2.0 without external power and this one works perfectly.

I just bought a HD Enclosure from Vantec, thinking I can reuse my old 1.5TB hard drive for backup the cloud. I am getting error code 1122. Waiting for WD support to respond.

I was using a Seagate expansion drive (3TB) and it was creating the share at first, but then…along came Error 1122.

When I tried to re-start the share by disconnecting and reconnecting the drive I got error 1123. No amount of re-booting and re-starting my system will allow my network to see that drive again. I’ve contacted WD customer support and I’m awaiting a reply. I’ll let you know if they are able to sort me out.

I have two iomega lphd-up3 1 Tb usb drives, both of them show 0kb and are not recognized in My cloud. I bought a new toshiba 2 Tb drive that was recognized and seems to work fine.

I have a 2TB Iomega USB 2.0 unit that was initially not recognized by My Could. I cleaned the disk with DISKPART, and recreated a simple volume formatted as NTFS. No problem since.

I tried a SEAGATE BACKUP PLUS 3TB  (STCA3000101).  Was a good buy on Amazon.


The drive is recognized on the WD Dashboard as a USB drive with no data.  WD Quickview list the drive wiith only an option to eject.  Not able to access as a SHARE.


Converted drive to a 3TB GPT disk formatted NTFS.  Ran CHKDSK (WIN 7), no errors.  No change.


WD tech support had me try WD My Cloud SYSTEM RESTORE.  No change, and, my WD My Cloud still functions.


SEAGATE claims no firmware issue with drive.  WD states possible issue with SEAGATE drive compatibility and that is why price was low.  SEAGATE drive functions as expected with all other USB connections…laptop, desktop PC.


Other than this drive issue, WD My Cloud is great!

With the firmware update of today the problem is fixed. Now WD My Cloud recognizes my iomega usb hdd.

I have sold my seagate expansion 4Tb and bought a WD MyBook 3TB.

Plugged in and no problems at all, working on fw v03.01.03-127.

my 3tb seagate w/ the new firmware update is still showing 0kb