Coming out of standby I cannot access my network shares anymore, need to restart device

Since recently I’m having issues with my WD TV Live Streaming Media Player. I think I have it since the last firmware update (that had been waiting for a while before I installed it so maybe I jumped more than 1 version).

Some Context

I use (Windows) network shares.

I don’t use the media library.

During the night my homeserver (which has the network shares) automatically hibernates

Device Info: 1.12.14


I start my WD TV Live (comes out of standby), when going to Video or Files I’m immediately treated to a message saying: The last content source has been removed. Please select a new content source.

I then go again to the network folder (it finds the server, so network is ok) but it tells me: There is no media in the current folder.


Reboot the WD TV Live, so an actual device restart (which takes ages) and then I can just add the content source and it will not give me the error message that there is no media in the current folder, but just list the subfolders as it should.

It used to work that when I started the WD TV Live I could just click video and I could browse the folders directly, no error messages about the content source being removed or messages that there are no files in the folder. I guess there could have been a “feature change” so that the WD TV Live during the night (when it’s on standby) automatically detects that my homeserver goes into hibernation. However that doesn’t explain why when readding the content source it doesn’t want to list any files from it until I reboot the WD TV Live. I would still prefer if I didn’t have to readd the content source also though :slight_smile:

Just to make sure: I only have the content source has been removed message after coming out of standby, I’m not getting disconnected during playback or anything (because I saw some posts of people who have this issue)

Is this a bug that will be fixed in the future ? Is there something I can do about it (other than not hibernating my homeserver, because I do that to save power).

Thank you already in advance for any help :slight_smile:


Hi, you could try setting a static IP for the WDTV to see if you get a more stable connection, if that doesn’t work, try rolling back to the previous firmware version and try again. Follow the link below.

I’ve got the same issue Darthy.

I’m not sure if a static IP will solve this.  I get the exact same behavior, frequently but not consistently, with my USB drive attached directly to the WD.  It spins down when the WD goes into standby or after 15 minutes of inactivity.  When I wake the WD up from standby, the drive spins back up.  

If it gets up to speed in time, the WD finds it as expected, and all is good.  But if not, which frequently happens, I get the same behavior as the OP stated.  It’s rather ridiculous, I don’t know why the WD won’t just give it a moment and check again.  I have found the easiest workaround is go to the homescreen so it stops the error messages, and eject the drive.  Then go turn the drive off and back on, then after the drive is found, reinitiate Media Library.  

This is not good behavior.

Static IP didn’t work (didn’t expect it to but was worth a shot :))

Strange behavior though, for 2 days it worked fine … 3rd day was again an issue. So maybe it doesn’t have to do with homeserver shutting down during the night …

I’m not too keen on rolling back the firmware to be honest, I can live with it for now, as long as I know it will be fixed in a future update. For the other people who are having this, do you only have this problem since latest firmware or also before ?



Well, my problem is somewhat different since it occurs over USB when coming out of standby, and the drive is also spun down.  I would say if anything, the problem is less severe since the firmware update.  The WD used to corrupt the file system on the drive, it hasn’t done that lately.

i also have the same problem, my smp is attached via wired connection to my pc, everytime i turn the smp on i have to go to system settings and reboot it to get the player to compile the library again otherwise i always get the “last known source removed” error, i think this happens because i switch my pc off at night, and because the smp doesnt properly shut down it thinks the drives have been removed, this is a pretty rubbish feature, id like to be able to fully turn the smp off when not in use instead of standby all the time

Same here, but this happens even if i dont shutdown my computer.

Everything works fine (after rescanned the library) then i restart (the quick way) the SMP, enter Library and it says “T__he last content source has been removed”, go to Settings and rescan library, everything works fine again.

I share movies, (100 maybe?) and some Tv-series and it takes about 1-2 minutes to rescan, but anyway :slight_smile:

Really would love a fix for this!

I had the same issue: see my posts hereand here. in the end (and after a lot of testing, WD said it was an issue with my router, not renewing the IP lease, and that several Netgear routers have this issue.

I have had a number of goes with other systems and had no similar issues, so I believe the issue is really with the WDTV. I returned the unit to WD as they only confirmed the issue after my ability to return the item to the shop had expired, and got a refund (though that did take a month to come through).

I now have a Rasperry Pi running Raspbmc (a varient of XBMC) which does exactly what the WDTV should have. With a bit of hobby work I have even housed it in a flash little housing and made it look like a commercial product.

I am not slating the WDTV, for those who have it working reliably it is a great unit - if it worked reliably I would have been happy with it. I am more concerned that theree seem to be a lot of users with very similar issues for whom the device does not work as expected. If XBMC can do everything reliably with no major corporation behind it, why can’t WD?

Thanks Salawinder, I read your posts and have the same issue.  

I don’t have a Netgear router, and it looks like WD is just trying to deflect blame on this to something else.

Would it help if I made a ticket in the forum “WD TV Live Streaming: Live Streaming Issues” ?

Would just like to know if they are planning to adress it in a future update …

I’m having a similar if not the same issue.  I just got my WD TV Live for Christmas and updated it to the latest firmware 1.12.14.  Every time the WD box goes into standby it takes a while to compile the library which is a bit of a pain.  If my computer which has network shares is shutdown at night, the WD box thinks the shares are gone.  I have to go back into the setup and rescan the network shares from the media library.  This once again causes the WD box to recompile the library.  I’m considering rolling back to an older firmware but this one is working well aside from the networking issue.  Netflix performance has been solid.  I should also mention that the WD box and my pc have static IP addresses.

If anyone has any suggestions or updates on this please let us know.



Has anyone ever found a fix for this issue? I’m having the exact same problems and it happens on 2 separate WD TV Live (New) that have both been updated to the latest firmware. It has been tried on from 2 completely separate homeserver on 2 different networks that use 2 different routers (One Actiontec & one Siemens), and the exact same scenario happens with both. the only difference is that I completely shutdown my homeservers, and do not put them in hibertnate. 

I get so many issues with it, including this one, I don’t know if solving this one alone would help. I’m using a wired connection not to a Netgear router.

I have two Window 7 PCs (Pro and Home Premium) connected via Cat 6 wire to a Linksys WRT310N router. The PCs have static IPs. The SMP, v1.13.18, connects via wireless to the router with a static IP. I do not have logon passwords on either PC.  All networked devices are in the same workgroup, not using Windows Homegroup. I am sharing my Windows Public folders on both PCs.  My wireless connection is solid. I am able to transfer files from and to the SMP via the network. Windows Media Share is solid between the Win 7 PCs, but it does not support separate subtitle files like .SRT which why I use Network Shares. 

When SMP exits stand-by, one or both of my PCs are listed in the Network / Windows Shares List.  If I select which ever PC is listed, the default logon screen is displayed (Anonymous and blank password). If I submit the default logon, a user and or password error screen displays. I have never found a user or password way out of the error screen except rebooting the PCs. After the reboot, the SMP excepts the default logon and all is well again until the next time the SMP goes into stand-by mode. I really hate rebooting my PCs every time I want to use the SMP and Network / Window Shares. Also, the Win 7 PRO PC disappears from the Windows Share list. I have found no reason for the PC dropping from the list. If I reboot, it is back on the share list. I have tried Cat 6 ethernet cable to the SMP, but it did not change anything described previously. Finally, restarting the SMP may or may not correct the issue described.