The WD My Passport (usb) stopped working today. When I plug it in, the light flashes steadilly (2.5/sec?), but it clicks. Is this a code? It doesn’t seem consistent. How many clicks make up the code? The clicking stops after a minute or so. Where do I find what the code means, if anything>

I’ve had the drive for 2-3 years now, with no problems. Using Win8

The actual problem is I’ve never backed it up. Any yeah, I’ve been meaning to lately… So stupid.

When I go to DevMgr, it shows the drive is ‘working properly’, but the volume are 0. Click on the icon, and it’s ‘unavailable’. 

I’ve tried different usb ports with no difference. I haven’t tried it on another computer yet, but expect the same. 
I looked at the manual, and couldn’t find anything about the clicks. 

Any suggestions? Of course, all my stuff is on this drive. 

I had a previous WD USB, and it corrupted after ~ 3 years. I lost some data. I wasn’t too happy…


Welcome to the Community.

Have you tried changing the USB cable? A clicking sound usually indicates insufficient power distribution.