Hello, I’m getting the error message "Something wrong with the volume’s CNID DB, using temporary CNID DB instead.Check server messages for details" since Saturday. Can someone guide me to fix it? I have the 3TB version. It’s almost 3/4 full and I hope I don’t have to re-format. Thanks.

Have the same problem…

Has the CNID DB error been solved?

Brand New WD live - same problem…

Have you all updated your firmware?   This is addressed in the FW released on 11/17.

I also have a brand new My Book Live, with up to date firmware, and I also get this CNID DB error message. Can anyone direct me to a resolution?

Hopefully you didnt load too much Data on it.

My cure was a factory reset - now MBL works like a charme!

@rockstar_DA Did you do a factory reset then the firmware upgrades to get it working, or just the reset? Thanks for answering.

After installation I did the FW update (got the CNID error before) and hoped it went away - no go.

Then after hours of websearch and crawling through this board I decided to do a Factory reset (yes - sure - AFTER I transfered files! *ARGH*).

After the reset the CNID errors were gone and the MBL worked propperly…

I did just the mini Factory reset (first option)

Hope this helps.


Thanks for the suggestion. I can’t even access the web interface today though. Just coming up as a blank page. So I’m not sure how to even do a factory reset without access to the admin centre.

What a waste of money. Plug and play? Hardly. Do WD read these forums or do we have to be more publicly vocal to get support usually?

did you enable ssh access before?

if so, you can upload the firmware via sftp and force a reinstall with the following:

(not sure if you have to copy the firmware first to /CacheVolume - that should bring back your scrambled GUI.) /CacheVolume/updateFile.deb


Thanks for the help. A factory reset did the job.