Cloud light blinking for hours

I don’t know if this is related to the recent firmware issues.  I have not been able to connect to MyCloud in any form.  I unplugged it and plugged it back in and it has had a yellowish blinking light for about 6 hours now and I am still unable to connect.  If this is a firmware problem, how can I install new firmware if I am unable to connect to it?  Is there some way to reset it safely so I don’t lose my data?

See the User Manual P.10, LEDs.

 

Have you tried shutting it down and waiting for a while before starting it back up?

 

Posted by,
cat0w (USA)

 

1 Like

The yellow blinking light means the mycloud is unable to establish a network connection with your Lan Router/Switch.

This can mean:

  1. Network cable not connect correctly, or router switch not switched on. You should have a green light showing in the rj45 plug in the rear of the mycloud.

  2. Most likely, mycloud is unable to negotiate an ip address from the router in DHCP mode, or you have set a 

static ip address out of range for the router/switch.

1 Like

Thank you.  I have a bad switch!  Problem solved.  Thank you.  I don’t have the manual either so thank you for that link as well :slight_smile:

Bill