Cloud Access Code Generation Error

Hello,

I’ve had no problem with cloud access or generating codes for access in the past. 

Today I tried to generate new codes for a new user and device and I keep getting an error. 

On the Add Cloud Access Window I get no code but instead dashes and an odd expiration date.  See below.

Activation code successfully generated. Enter the code in the app on your mobile device.

Activation Code
--
Expiration
Wednesday, December 31, 1969 7:00:00 PM

After this, I see a New Unregistered Device in the Cloud Access / Configure Access pane.  The Clock Icon has an X and if I try to delete the erroneous code by clicking the trash can icon I get the following error: 

Device user ID missing. (400014)

My firmware is up to date, internet connection is sound and i get access on previously set up devices.  What gives?

Thanks for any help you can provide.

Have you tried rebooting/restarting your WD My Cloud Mirror? It could be a system error.

Thanks for your reply Trancer.  I have rebooted and restarted the physical device, and also disabled and enabled Cloud Access in the General Settings of the device (using IP address of device in web browser).

Can you provide more detail about your suggestion?  How do you reboot the WD My Cloud Mirror?

Thank you.

You mean resetting the device with the reset pin behind it?  No I haven’t done that.  How is that different than shutting down (from the web based dashboard) and restarting the machine?  And does resetting the device in any way threaten the integrity of the data thereon?

PS.  I have an EX4.

It seems that my cloud access cannot get a remote access connection.  How do I fix this please?

Cloud Access

Cloud Service
ONOFF
 
Connection Status
Failed  
  Cannot establish remote access connection. Make sure you are connected to the internet.

You can try forwarding ports 80 and 443 to the EX4. This varies from router to router but take a look at this link.

How to enable port forwarding on a network router for use with a WD My Cloud, My Book Live, or My Book Live Duo

Thanks.  I can definitely try that - it’s just that I’ve never had this problem generating codes until recently.  I wonder what changed?

OpusKV626 wrote:

Thanks.  I can definitely try that - it’s just that I’ve never had this problem generating codes until recently.  I wonder what changed?

 

As long as you haven’t changed anything, then your router blocks the EX4 from having internet access.

The Cloud service in Automactic mode establishes a conenction from inside the EX4 to the Cloud servers, so you don’t need to forward / open any port in your router.

If you have changed the Cloud Cofiguration from Automatic to Manual, then you need to do a port fowarding in your router to let the EX4 connect to the Cloud servers.

Best would be to check the Cloud Confugartion and set it to “Automatic”, then wait for approx. one minute to let the connection being established from EX4 to Cloud.

Nothing was changed at all.  I recently tried again and got a code to be generated.  Now the remaining issue is that there are multiple “unregistered new devices” entries for each user for which I tried to generate codes but got an error message.

When I try and select the trash can icon to delete the erroneous entries / remove mobile device, I get a new error message:

Error


  • Device user ID missing. (400014)

How do I delete those entries?

Thanks.

hi,
I have developed the exact same problem, reboot hasn’t done anything. Changing the Cloud Access Settings isn’t doing anything.
Have you resolved yours?
My firmware is up to date.

so my problems are

  • cannot generate new keys/codes
  • cannot delete old entries
  • cannot access the drive remotely
  • Cloud service reports as ‘failed’ (currently) BUT… has reported as working some of the time!!.
  • Attempts to access on wifi in-house from an iPhone yield “Invalid operation”, “A file already exists at this location, or an invalid operation was attempted” - which is not the most helpful message for me.

My router is set up for UPNP, so the auto option for cloud access should just work. Why doesn’t it?

Can anyone help?

@Martipops What router make / model and ISP?
What DNS server is your router using? Is the router itself, ISP DNS or other external DNS Server?
Can your PC / Mac resolve mycloud.com and wd2go.com ?

                MyCloud allows the user to set their own DNS server on MyCloud device.
                Have you tried setting your MyCloud DNS server to Google's and reboot the system?

Hi SBrown,

It is an EE Home broadband router Hardware version 1.

The DNS is acquired from the ISP, and passed to the other devices (including the EX4) via the in-house DHCP.

I can resolve mycloud.com, but although wd2go.com yields an IP address, that address doesn’t respond to pings. (txt snap below)

Microsoft Windows [Version 6.1.7601]

Copyright © 2009 Microsoft Corporation. All rights reserved.

C:\Users\martin>ping mycloud.com

Pinging mycloud.com [129.253.55.56] with 32 bytes of data:

Reply from 129.253.55.56: bytes=32 time=174ms TTL=238

Reply from 129.253.55.56: bytes=32 time=197ms TTL=238

Reply from 129.253.55.56: bytes=32 time=168ms TTL=238

Reply from 129.253.55.56: bytes=32 time=178ms TTL=238

Ping statistics for 129.253.55.56:

Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

Approximate round trip times in milli-seconds:

Minimum = 168ms, Maximum = 197ms, Average = 179ms

C:\Users\martin>ping wd2go.com

Pinging wd2go.com [54.213.108.157] with 32 bytes of data:

Request timed out.

Request timed out.

Request timed out.

Request timed out.

Ping statistics for 54.213.108.157:

Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

C:\Users\martin>

So ……… I set the google DNS details (8.8.8.8 etc.) and rebooted the server.

And….

The cloud access screen looks like this.(pic embedded)

What else can I do to try and clear things?

Cheers

M

Hi, - could you trash the pic with my email address in it once you have seen the screen?

thanks