Clock & location related issues

1.) Does resetting the location also reset the clock? If yes, why is the time currently about 5 minutes ahead? Tried it twice, even after resetting the device to factory defaults. No dice.

2.) How can I manually set the clock?!

3.) Why is the location-detection not properly setting the Daylight Saving configuration? Central Europe == Daylight Saving on (at least for the next ten days).

  1. No.

  2. You can’t.

  3. Because Daylight Saving doesn’t use location detection.   It’s a manual setting.

No chance of manually changing the clock is disappointing, to say the least.

Do you know how often the device is trying to get the correct time from a time-server? I don’t want to keep the device running all day long.

schwurbel wrote:

No chance of manually changing the clock is disappointing, to say the least.

 

Do you know how often the device is trying to get the correct time from a time-server? I don’t want to keep the device running all day long.

I have no idea – I’ve never seen my clock more than +/- 1 minute.   And a simpe restart has always got it back to in sync within a few seconds of my NIST-based clocks…

schwurbel wrote:

Do you know how often the device is trying to get the correct time from a time-server? I don’t want to keep the device running all day long.

Many of us leave our WD players on 24/7.  It uses a trickle of electricity to do so and is always ready to get going; no boot-up wait.

Indeed, my Roku media player doesn’t even have a power button – it is always on when plugged in.

mike27oct wrote:

Many of us leave our WD players on 24/7.  It uses a trickle of electricity to do so and is always ready to get going; no boot-up wait.

Indeed, my Roku media player doesn’t even have a power button – it is always on when plugged in.

Exactly. When I got my first WD device (Live+), I used it as a media and data hub with two USB drives attached, and left it running for close to two years straight. The box still works flawlessly today.

As far as the Roku, I was shocked when I bought my first one of those that it had no on/off switch. I have no idea why their development / useability team opted to go that route, but as they have sold over 5million units in the US alone since 2008, I’d say that people seem to have adapted to the “always on” concept.

-P

Yep, but the Roku can still freeze up once in a while, and why have it (and my WD) plugged into their own inline on/off wall wart switch.  Easier than unplugging unit in tight places.

First: Please move your off-topic chatter to some other thread, this one is about clock-issues.

Second: Restarting the WDTV with it being unblocked from accessing the internet fixes the clock being ahead. So it’s only checking the NTP-server once during startup, with a nice little bug to boot: http://community.wd.com/t5/WD-TV-Live-SMP-Issues/Remove-Developer-Code-Pt-II-NTP-Server-spam/idi-p/423630 (yes, it’s still in 1.16.13).

If anybody from the powers that be read this: Please also try to reset the clock upon resetting the location and/or setting the timezone. Or just add a way to manually set the clock…

Out of interest how come it only seems to affect you and does this mean that you never power down now as mentioned in what you call off topic chatter.

Later.

I just re-powered my SMP with it connected to the internet and the clock is correct to the second.

Agree with Rich’s comment.  Nobody is off topic here; it’s all related to YOUR problem.  We are trying to help you, Dude, so chill out and don’t be so quick to scold. 

Anyway, I don’t give a rip about the clock in the WD player – really, what good is it for anyway – am I missing something important to know about this clock?  If I want to know the EXACT time I look at my atomic clocks around the house.

richUK wrote:

Out of interest how come it only seems to affect you and does this mean that you never power down now as mentioned in what you call off topic chatter.

I’m blocking it from accessing the internet. The online services I would want to use are either broken or crashing the device, so there’s no point in letting the device have full access to the net, when I have no idea what it’s doing.

It’s not like it didn’t do some shady things with full net access in the past, like http://community.wd.com/t5/WD-TV-Live-SMP-Issues/Remove-Developer-Code-Pt-III-console-sniffer/idi-p/424496

As we’ve verified that the automatic clock-setting happens on reboot, this thread can be closed. Thanks.

PS: Talking about how long and why you’re keeping your WDTVs and Rokus powered-on is off-topic in a thread about clock- and location-settings.

Oh great; another self-appointed Board Moderator with an attitude.

That’s Schwurbel for ya. At least he’s consistent :wink: