Clickatell API not working


I’m trying to use the Clickatell API for send SMS notifications. When I paste the API in the settings, it says “The url is not a valid value.”

API: world

Any help?

1 Like

What does Clicktatell API have to do with the WD My Cloud? More information is needed including what My Cloud model you are using (if any).

I use the My Cloud Gen2. The problem is not the API, because it works fine.
When I set the URL in My Cloud with “Hello world” message, and then I save, it says the URL it’s not correct.
Some years ago, there was an API like the example in form of My Cloud settings, but then changed, and it seems My Cloud doesn’t update it…

What does “set the URL in My Cloud”? What URL, from where? The web portal? The My Cloud app? Are you trying to “share” a URL to a My Cloud file/folder through SMS? It is not clear (at least to me) what you are attempting to do and what steps you are using and where the error is occuring.

When I access from the IP to the config panel, in Settings tab, there are Notifications. Then you can choose email or SMS.
I’m trying to set SMS Notifications, where do you have to provide an URL of an API which entering it, it sends a message saying “Hello world”.
And when I write the URL of the API of Clickatell, it appears a pop-up saying it’s not valid.

It is possible that’s another lovely bug in the single bay My Cloud Gen 2 Dashboard. While the single bay gen 2 My Cloud User Manual shows a graphic indicating an SMS option, SMS is mentioned nowhere in the Notification section or anywhere else in the User Manual.

I’ve got the same issue with WD MyCloud EX2 Ultra (latest firmware). I subscribed the service, tested the messages, all working… I’ve got £10 top-up and now I can’t use it as the FW doesn’t accept the format. WD should really look into this problem, but I solved :wink:
I just copied the example URL in just to see what’s the next step. The FW takes the variables out from the URL and at this step it asks you to match the variable names to the standard ones, like which variable means the “user name”… etc. As the new API URL doesn’t have these variables any more, just the API key, addressee and text message, it becomes invalid. I’m contacting the Clickatell soon to get a solution for this.

I didn’t contact the Clickatell as I found the solution on my own. So I tried to use the example URL like this and it works:

The URL is working in browser (Firefox), I receive the text but the interface is still crying :frowning:

It finds the API key invalid as it expects numbers. So type any random numbers then you’re allowed to go to the next step. Match the variables to the fields here and at the final step you can enter the valid API key. And all done. However, the interface popped up with an error message, I received the test text.

  • SMS service provider: any names you like
  • URL:
  • Replace space character with: not set
  • Phone number1(to): phone number with country code
  • Phone number2(to): not set
  • User Name(user): login email for Clickatell
  • Password(password): login password for Clickatell
  • Other(api_id): the long API Key (== at the end)
    This is based on the previous step where you matched the fields to the variables. Variables are in brackets.