Click of death on WD passport 1tb 2013?


I wanted to ask for some help on my wd passport 1tb that recently occured a click of death on me all of a sudden while i was transferring data from my wd passport to another drive. Bought the passport around december 2012 and exacly 1 year after that, the passport gave me a click of death and all my data are inside. I bought the passport via online and apparently I’m going to get into trouble when I want to claim a warranty.

The problems are

  1. after plugging the passport into the pc, passport starts, hearing the passport has a constant clicks

  2. opening the drive from windows explorer would make the explorer.exe not responding

  3. I am unable to uninstall the passport’s driver through device manager

I need help in the #3, I might able to get it working (hopefully)

Thank you in advace


You should try some basic troubleshooting.

1- Disconnect the drive from the computer and restart the computer.

2- If the computer is a desktop, connect it on the back USB port (directly to the PC, not through a hub).

3- Make sure you hear the connection sound windows makes when recognizes a USB device.

4- Go to "Disk Management” to verify if the drive shows up there.

If the drive shows up in disk management but it is not seen on Computer, then it means the partition is corrupted and you will have to format it in order to use it again. Please note that formatting the drive will delete all data stored on it.

 It may be possible to still extract the data utilizing data recovery software. Western Digital does not provide data recovery software. However, there are several kinds of Data Recovery software available. If you do a  web search for  Data Recovery  it will yield plenty of data recovery software options.

(If the drive is still under warranty it does not matter where you have purchase it. WD will still replace it.)

Hi, thank you for your response, here are my answers

  1. It is quite useless once the drive is connected, it will make the explorer.exe somehow ‘deadlocked’ when restart, had to do hard restart by pressing reset/power button for 5 seconds

  2. I even tried on my laptop, it is the same

  3. It does recognizes the USB, but I also hear the drive, it is spinning but I could hear a constant clicking sound

  4. If I go to the disk management, the process will also goes into not responding state, even if I tried to remove the drive’s driver from device manager, nothing happened and disconnecting the drive’s cable would also renders the driver uninstallation process ‘not doing anything’

One last thing though, I tried the MHDD tool, tried to connect to my laptop via USB and left it for about 7 hours for it to somehow ‘initialize’ the drive in hoping to recover from click of death just like what I did on my Seagate drive that occurred to me last year, the tool are unable to proceed due to the drive ‘unable to initialize’

Thank you in advance