Clean OS (Debian), OpenMediaVault and other "firmwares"


#1519

@ZeryOs, try erase HDD before repartition (Before “parted” command):
dd if=/dev/zero of=/dev/sda bs=1M count=10000


#1520

I did that and still stocked. I’ll let it run an hour or so and see if it goes further but doesn’t seem to work.

Can you “push” the firmware upgrade via Ubuntu?


#1521

Update kernel to 3.2.68 (On my website / g.drive folder).

Hm, it seems like I already have 3.2.68 installed.

root@MyCloud:~# uname -r
3.2.68

Do you mean these files?


#1522

I’ve done the whole process again. No errors whatsoever but still not making it work. It won’t appear on my network and the let is steady yellow light.

Any ideas? @Fox_exe


I managed to get a green light!!

But it wouldn’t connect to it. My router doesn’t show it and this is my “intarfaces” config:

> # interfaces(5) file used by ifup(8) and ifdown(8)
> # Include files from /etc/network/interfaces.d:
> source-directory /etc/network/interfaces.d
> 
> #added
> /ipv6/d
> /inet6/d
> 
> 
> # loopback
> auto lo
> iface lo inet loopback
> iface lo inet6 loopback
> 
> # main network interface
> auto eth0
> allow-hotplug eth0
> iface eth0 inet dhcp
> iface eth0 inet6 dhcp
> hwaddress ether XX:XX:XX:XX:XX:XX
> ##	pre-up echo 1 > /proc/sys/net/ipv6/conf/$IFACE/accept_ra
> ##	pre-up echo 0 > /proc/sys/net/ipv6/conf/$IFACE/disable_ipv6

That’s after following instructions in this topic. The device won’t show in my router and don’t know what to modify now. What should I try next?? Help here in the last step!! @Fox_exe @hvalentim


#1523

So has anyone loaded this on an EX4?

I have been trying to read through 4 years of comments to get the latest information but what I really need is just a step by step on how to get this up and running.

I found the EX4 folder but I don’t see any autostart.sh script like I see in some of the comments.

I have seen comments saying that Clean Debian and OMV is part of the install etc other make it sound like separate installs.

The OMV website does not really explain how to get OMV installed on my EX4 so I am just a little lost on where to start or how to get a useful OS on this EX4.

Any help would be appreciated.


#1524

@schrammbo, autoinstall.sh - only for Gen1 (one disk) device.
All devices have different install methods, becase its have different hardware.
For Ex4 - try this: https://fox-exe.ru/WDMyCloud/WDMyCloud-Ex2-Ultra/Debian-linux_4.14.4/ (I think a Ex4 and Ex2u is same devices)

Clean debian - is a Debian Jessie (Or Stretch), w/o any modifications and additional software. Only few fixes for work on our devices.
OMV - Separate software. Need install AFTER debian (Inside debian). Follow this guide: Scroll down to “OMV setup” section.

  • Possible to use “Arrakis” (v4) instead of “erasmus” (v3)

#1525

@Fox_exe Thanks for the clarification!

Looking over the steps it says to copy of the uimage, uramdisk and rootfs-jessie.tar.xz

I assume rootfs-jessie.tar.xz is the same as debian-jessie-rootfs.tar.xz however, I am not seeing the other files are they located elsewhere? I did locate within the comments the Google Drive location that pointed to an EX4 folder which had uImage-4.8.6_ex2u.bin. I assume that is the same or similar. I was not able to locate uRamdisk anywhere in these locations unless that is the MCMgen2-jessie-basic-armhf.tar.xz file which is in the same folder as the uImage file.

Lastly I realize this is most likely a stupid question but I suspect that I am doing all this via SSH to the EX4 and somehow (using SCP or something) getting these files into the locations mentioned?? For some reason this EX4 is not allowing SSH connectivity even though it is configure to allow it.

I may need to reset the device back to factory to get that working.


#1526

@Fox_exe

Thank you so much for your brilliant work!!!

I managed to install Debian on MyCloud (Gen2)
— STRECH 9.3 and OMV 4.1.0-1 (Arrakis) —

I cant use the “Debian-kernel-bin_4.15.0-plus.tar.xz” from your repository.
It only gives my a blue, blinking light and no network, is there a way to use it or only a test?

THANKS
puxxi2003


#1527

@puxxi2003

Where did you get the files needed for uploading? I am not able to find all the files I am looking for.


#1528

the first post?

Speciffically here:

Primary File Archive: http://anionix.ddns.net/WDMyCloud/
Mirror: https://drive.google.com/open?id=0B_6OlQ_H0PxVRXF4aFpYS2dzMEE


#1529

Thanks…I guess that makes sense.

I was going off the link Fox gave me previously and did not see the uimage or MCMGen2* file in the link Fox provided.

Probably because I did not go to the original link.

Thanks.


#1530

@Fox_exe

My EX4 does not have a /boot directory so I assume I can create one to dump the necessary files into?

If I am creating a directory this will undoubtedly cause the filesystem to become full. Is there anything I can get rid of to make space for the necessary files I will be moving?


#1531

@schrammbo, for Ex4 use instructions from Mirror Gen2 (Ex2 Ultra) - Its same device, but have different RAM size.
So - all files compatable except for uImage (Kernel is same, but different DTB inside)


#1532

@Fox_exe

I really hate to keep bothering you on this as the instructions you have seem fairly simple however, I cannot seem to get past step 1.

I am using the instructions for Gen2 (Ex2 Ultra).

Step 1 says:

  1. Go to web panel and install .bin file as regular firmware

When I attempt to do that all I get is firmware update failed.

I have both the uImage bin file and the Debian-firmware bin file. It does not say which to use (I assume the one marked firmware) but have tried both and the result is the same. Do I need to change permissions on the directories somewhere or move the files manually to the device somehow?

Uploading over the web console is not working in this case.


#1533

Sorry, my mistake.
Ex4 have old cpu - Marvell Sheeva (Kirkwood / 88F6282 / ARMv5) SoC. So its not compatable with all other MyCloud’s.
Need different firmware.
I dont have it.

But you can install “Chrooted debian” if you need some “special” software. But not full-firmware.


#1534

Hi, I have the exact same problem like @ZeryOs :unamused:

I just wanted to swap hdd in my wd my cloud gen2 and followed @Fox_exe 's unbrick guide.
Right now I have a blinking red light and can reach webif of safety/recovery mode.
But uploading the newest firmware .bin file leaves me with 0% loading circle freeze.

WD download site states, that the .bin should be extracted to get a .zip file and upload that file. Could this be the problem?.. However I cannot extract the .bin file…I’m too scared to just rename the .bin file to .zip.

Any help is appreciated.


#1535

I finally got it to work and I’ll try to compile the whole process into one topic if it works with people.

Anyway, my question now is… what is the best way for me to install NextCloud. I need it because of its functions.

I have the WD MyCloud 2Gen.

Thanks for everything!! @Fox_exe


#1536

Log after upgrade Stretch WdMycloud Gen1

I post the logs of WdMycloud gen1 after a stretch upgrade, the device start, green led, but no response in ssh.

If an advanced user could take a look, it would help me a lot.

Can be a track : pfe_firmware_init: request firmware class_c2000.elf failed
pfe: probe of pfe.0 failed with error -110

Thank you in advance.


#1537

Hello!

I had a problem with this device (WdMycloud Gen1). After some manipulations (update and attempt to install Russian locales) via SSH, the web interface and access to the device from the phone ceased to be available. I stumbled on the Internet and came across this article, I wanted to put a clean debian and then install the device on my own. There was no certainty that everything would go fine and decided to start off the settings for the standard (power off / hold down the reset button for 40 seconds), but after that SSH is not available, only the network folders on the device are visible and you can work with them. How to be in this situation? Where to begin?

Thank you in advance!


#1538

Which file of clean debian should I use for latest version of OMV (erasmus)?
|Clean debian - english.7z|18-Jun-2017 23:14|511 MB|
|CleanDebian-Jessie.tgz|28-Nov-2015 20:39|497 MB|
|CleanDebian64k.tar.gz|14-Mar-2015 23:40|392 MB|

edit:
And which install.sh should I use? From Autoinstall or Debian archive?