Clean OS (Debian), OpenMediaVault and other "firmwares"


#1226

Base image - from Debootstrap (Im use tutorials for RaspberryPI).
Plus few modifications and additional packages for run on our device (Kernel modules, openssh-server etc…)
Result fimware builded by “mkimage” tool from WD GPL source code achive (Firmware header explain, all other - can be found in wd source archive))
“Initrd” - From “Buildroot” tool (Plus custom startup script).


#1227

Hi @Fox_exe
I noticed that just came out the sources of Synology DSM 6.1-15047.
This time they are available as well the kernel source!
Would you like to try compiling the version for WDMC Gen. 1?
Maybe with these sources you will not have problems dwc_otg
Waiting for your own great magic I offer you my congratulations on your workings


#1228

Hello !

I have a 3tb My cloud NAS and i wanted to know if its possible to put Plex in ? Maybe with a raspberry pi or Debian os
Thanks !


#1229

Hi everyone!
I’m just installed DSM 5.2 on my My Cloud 2TB Gen1. I like it so much, so thank you for your work. Is there any chance for DSM 6 on G1? :slight_smile: Thanks! :slight_smile:


#1230

what is DSM ?


#1231

Disk Station Manager (this is the OS for the Synology products)


#1232

ow ok… i have a mycloud thats why.


#1233

It’s available for some MyCloud devices (Thanks Fox_exe!).


#1234

Hi guys, i use Clean OS since three days on my WD MyCloud Gen2 2TB with the jessie root fs from 14-Sep-2016 11:43 from the thread entry. USB isnt working. It seems there are drivers missing. Is the a fix / patch available to get usb to work? Best Regards, Florian


#1235

@Fox_exe

My mycloud gen1 upgrade memory, K4B2G1646E-BCK0 (256M) up K4B4G1646E-BCK0 (512M), very sorry to enter ssh, free display memory or 256M, whether “barebox” also need to change?
The above content machine translation.


#1236

I can’t seem to make it work.
I’ve got a GEN2 WD MyCloud with an 8T disk, firmware 2.11 (says there’s a 2.16 update but I’d rather not try), and busybox (files in /bin links to busybox at least)

cat /proc/cpuinfo (snipped)
model name : ARMv7 Processor rev 1 (v7l)
Hardware : Marvell Armada 375 (Device Tree)
cat /proc/meminfo
MemTotal: 514528 kB

I copy to /boot/boot/ the required files from /WDMyCloud/WDMyCloud-Gen2/Debian (uImage, uRamdisk and jessie-rootfs.tar.gz, check the permissions

total 322252
drwxr-xr-x 2 root root 4096 mars 27 23:39 .
drwxr-xr-x 4 root root 4096 janv. 1 2013 …
-rw-r–r-- 1 root root 104486912 janv. 1 2013 image.cfs
-rw-r–r-- 1 root root 104484864 janv. 1 2013 image.cfs.sep
-rw-r–r-- 1 root root 114995215 mars 27 23:39 jessie-rootfs.tar.gz
-rw-r–r-- 1 root root 3321289 mars 27 23:38 uImage
-rw-r–r-- 1 root root 2680403 mars 27 23:38 uRamdisk

But at restart the MyCloud flashes blue for a small while, then keeps flashing yellow/red alternatively (for hours). I’ve tried redownloading the files, copying from a linux computer to the harddrive connected in SATA3, to no avail. There doesn’t seem to be a MD5Sum to check the files, but they seem ok (jessie extracts without problems).

Is there a step I’m missing?


#1237

@k_unc Need change memory size in kernel (/arch/arm/mach-comcerto2k/ …). Its hardcoded.
For newer device - need edit DTB (dts file in /arch/arm/boot/dts/…).


#1238

@Fox_exe Hi. First of all. Thank you for your work. The root fs of jessie is from autumn last year. usb port isn’t working. is there any solution / fix or must i use dsm 5 to get usb to work. my device is a my cloud gen 2 single bay. thank you in advance


#1239

@HRVSTR, can you specify which files you used among these available (cleanDebian*, kernel and rootfs*)?


#1240

Edit: Sorry, just re-read the question:
I am now using CleanDebian-Jessie (28-Nov-2015 20:39) with the stock rootfs and kernel from Fox_exe’s archive.


#1241

@Florian_Hahner - Use alternative kernel (Or stock).
Its easy to fix. Just need rebuild kernel with few additional modules. But i dont have time for this… Many work…


#1242

Hi, thx for reply. As i reinstalled clean os i regocnized, that, if you connect your usb device before power on nas, it will be accessible within debian. If you connected it after linux startet, you arent able to use it. Hope this helps. Best regards and thank you for your work !!!


#1243

I managed to brick my device – kind of :frowning:
Since my attempt to switch from WD to DSM failed (flashing red LED after reboot), I followed your guide to unbrick the device using a USB stick. I followed the instructions thoroughly and I was finally able to boot into the latest original firmware (2.12.126). The problem is the whole process seems to have messed up the partitions. The system does not properly recognize the internal HDD. Neither a factory reset nor formatting the drive solved the problem.

When I go to the webgui there’s a dialog to set up a RAID. I clicked on it and since I only got one HDD it asks me to use JBOD instead. I get past a so called disk self test and it seems to even partition the Disk but when formatting it ends up with error code 635.

I know it’s a lot to ask, but any idea how to fix this?


#1244

just to be on the safe side: did you use the autoinstall script? my doubt is that in the autoinstall package there are two config images, 1K each, and these are referenced in the script, while in the CleanDebian-Jessie there isonly one config image, different size, different name hence it won’t be used by the autoinstall script at all.


#1245

Sorry for replying so late. Yes, I used the autoinstall script to install DebianJessie. I never really checked what the script actually does but it worked flawless two times including the run_me_after_install.sh.