Clean OS (Debian), OpenMediaVault and other "firmwares"

Thanks for your reply.
So:

  1. The .bin files for clean Debian 8.0 in the “EX2” folder dont install on my EX2 through the WD Webgui
    (I wanted to install clean debian first)

  2. I did manage to install “Debian-jessie-firmware-test” from Gen 1 “Mirror” folder

  3. So what is the difference with the clean debian and the debian-jesse-firmware-test ?

  4. If I do as you instructed in your recent reply to my post, then after reboot -f how to install omv?

By the way I tried the DSM 6 as trial installation and it works great. Only problem is that my windows PC’s cant see the drive and I cant map a folder or see shared folders…

I do :slight_smile:

hi
I have my cloud home 4TB
and I can’t understand how to use this firmware
can you please give me instraction video to learn us how to install it step by step

This firmware (for single bay My Cloud units) won’t work with a My Cloud Home because the My Cloud Home is a completely different device than the My Cloud units.

User Fox_Exe has some directions (in Russian) that may explain how to install Debain (of some type) to a My Cloud Home device. One may have to use a translation program/website to translate the information into their native language. See the file _Info.txt at the following link.

https://fox-exe.ru/WDMyCloud/WDMyCloud-Home/Debian/

http://4pda.ru/forum/index.php?showtopic=467828&st=12140#entry87961189

If one uses the forum search feature (magnifying glass icon upper right) they’ll also come across the following large discussion about Debian on the My Cloud Home in a different subforum (a subforum specifically for the My Cloud Home).

Hello all,

I’ve just purchased a WD Cloud EX2 Ultra, and I’m going to install Debian an OMV, but, I’m stuck in the first step, when I’m trying to upload the firmware over the Web UI. It always says “The firmware version you are trying to update is not compatible with your My Cloud system. Please download the correct firmware and try again.”
Any tips?
The stock firmware version is 5.09.115.

Many thanks for your help.

That may be your problem. One may have to find a way to roll back to the OS3 (v2.x firmware) for their device before attempting to run the steps to try and install Debian. Because you are both using OS5 and using a different device than the single bay My Cloud (the general subject of this My Cloud subforum/discussion thread) you may (if you haven’t done so already) want to see the dedicated OS5 EX Series subforum where there is discussion on the OS5 EX2 Ultra.

OS5 My Cloud EX Series

From there you can use the forum search feature (magnifying glass icon upper right) to find discussion on attempts to roll back to the OS3 firmware. For example see the following discussion in that subforum.

Hey Bennor,

Many thanks for your answer, make sense… I’ll start to read.

Cheers.

Edit: It worked, I’ve downgraded the firmware and installed Debian.
Edit2: It’s bricked now :slight_smile: after following the steps, on the first reboot, the box never get an ip, so I guess it’s bricked.

Hey Fox
hope you are fine my friend
i am running DSM on MyCloud EX2 and I would like to switch back to Original Firmware
can you please let me know how to install the original firmware back
thanks

Thejack here again.

I can create a recovery tool that reinstalls the correct firmware on the MyCloud EX2 Ultra, but for that, I need the data from the flash memory (I do not have it anymore).

Can somebody please hook up a root shell to a MyCloud EX2 ultra, and execute the following commands
dd if=/dev/mtdblock1 of=mtdblock1
dd if=/dev/mtdblock2 of=mtdblock2
dd if=/dev/mtdblock3 of=mtdblock3
dd if=/dev/mtdblock4 of=mtdblock4
dd if=/dev/mtdblock5 of=mtdblock5
dd if=/dev/mtdblock6 of=mtdblock6
dd if=/dev/mtdblock7 of=mtdblock7

This will create 7 files, which I need to create a recovery tool for the EX2 Ultra. These files contain parts of the original recovery firmware, which I - sadly - bricked on my device.

Yours sincerly, Jack

NAND layout (partitions)

/dev/mtdblock0 - "U-Boot"
/dev/mtdblock1 - "uImage"
/dev/mtdblock2 - "uRamdisk"
/dev/mtdblock3 - "image.cfs"
/dev/mtdblock4 - "rescue fw"
/dev/mtdblock5 - "config"
/dev/mtdblock6 - "reserve1"
/dev/mtdblock7 - "reserve2"

So, just use this tool: Fox_exe file archive
for unpack original firmware and get uImage, uRamdisk, image.cfs (rootfs) and config.tar.gz
First 3 - just “dd” into flash.
But for config - need create ubifs partition in /dev/mtdblock5 and upload config.tar.gz into this partition (overwrite all files)

On mtdblock7 (ubifs partition) you can find mac address and serial number (as files)

1 Like

@Fox_exe

Thanks for the pointers, I have used this script GitHub - michaelroland/wdnas-firmware-modding: Firmware Modding for Western Digital My Cloud DL2100 NAS Systems to extractthe firmware, but it creates faulty binaries. Yours does no, thanks for that.

I have created one at /dev/mtd5, but how should I name the volume?

However, I am stuck creating the ubifs, can you please give me some pointers here?
After that, I think it would be possible for me to create a script that reinstalls WD’s firmware, as it has been adressed multiple times here.

@all
I am still interested in a copy of /dev/mtdblock4, this device includes the recovery firmware. This would allow me to create an even better recovery tool, since it would also fix any broken recovery firmware.

Try to mount and analyze 6 and 7 partitions (Its Ubifs too). Config partition must be same.

Hi Fox,

just to confirm
I have downloaded teh firmware for EX2 unpacked it and i got 4 files

  • config.tgz
  • rootfs.cfs
  • uImage.bin
  • uRamdisk.bin

the MTD devices on WDMyCloud-Ex2 not the ultra are the following

  1. mtdblock0
  2. mtdblock1
  3. mtdblock2
  4. mtdblock3
  5. mtdblock4
  6. mtdblock5
  7. mtdblock6

to restore I should do the following

  1. ssh to my EX2 with the DSM firmware and do the following
  2. dd if=uImage.bin of=/dev/mtdblock1
  3. dd if=uRamdisk.bin of=/dev/mtdblock1
  4. dd if=root.cfs of=/dev/mtdblock3
  • any update on the steps above needed
  • Question : how do I create the ubifs Partion on /dev/mtdblock5 to put the config file

Yes, all is right.
I think Ubifs already present, but contains wrong or damaged configs. Just mount it and extract config.tar.gz into it.

ubiattach /dev/ubi_ctrl -m 5 -O 2048
mkdir /mnt/config
mount -t ubifs ubi0:config /mnt/config

There is example of creating ubifs image (and test in Nand emulator). Not for our device, but there is all useful commands:

thanks for your reply one last question
Ubiattach command is not available on DSM version any idea how to get it on DSM
also when i try to mount the ubifs i get the following error
mount: unknown filesystem type ‘ubifs’

is it possible to use this revert method
======== REVERT =========
dd if=/dev/zero of=/dev/mtdblock1
reboot -f

After this WDMC runs in “Rescue” mode. Go to webgui and upload original firmware file (.bin)

@diaahussein

It seems like you figured it out, however, I am not able to trigger the Safe Mode, because the /dev/mtdblock4 is corrupted.

Could you please hand me a copy of it? It would be much appreciated.

Thanks again, Jack

Hi Jack
My Box is EX2 not EX2 Ultra
I am not sure if the copy from it will work on your box they have deferent HW
my recommendations is to get the correct image for your Box EX2 Ultra
HW Specifications

Ok…
Dump partition (dd) and open it on PC (Ubuntu/Debian + apt install mtd-tools), update, then - reupload back to WD.

I installed this: http://4pda.ru/forum/index.php?showtopic=467828&view=findpost&p=87961189, it worked. I did the debian and OMV update. Unfortunately, now I only have SSH access. OMV does not start. Reloading does nothing. Please help. How Restore my Wd My Cloud Home?

Dear Fox!

Thanks again for your help, I really appreciate that.
I have now dd’ed uImage.bin to mtdblock1, uRamdisk.bin to mtdblock2, rootfs.cfs to mtdblock3, and executed the following commands on mtdblock5:
ubiformat on /dev/mtd5, then i have created an ubifs volume with the name config, that fills the whole device, and extracted config.tgz onto it.

Still, the device does not boot.

Any pointers?