Clean OS (Debian), OpenMediaVault and other "firmwares"

Hi! I have met exact the same problem with you, and I was wondering how you finally fix this. Thx a lot!

Hey @Fox_exe,

I’ve been running your Debian version on my EX2 Ultra for several months. Yesterday I somehow crashed it by installing samba. It never requested an IP after booting so I couldn’t ssh to try and fix it…
This evening I plugged both HDDs into a rack using another linux computer and re-applied the whole procedure to install Debian from scratch: https://fox-exe.ru/WDMyCloud/WDMyCloud-Ex2-Ultra/Debian-linux_4.14.4/
When I plugged the HDDs back in the NAS the power led was blinking blue and the disk1 led was rapidly blinking red while disk2 led was fixed blue.
Do you have any idea about how I should go and fix this?

Thanks for your great work!

I followed your instructions in summer 2017. I do it all to my WDMC Gen2 and all works fine.
In summer 2018 i updatet to debian 9 and all works fine :wink:
About 2 weeks ago I ran the updates again via omv. The updates went through without errors, but afterwards I had aborts with all copying processes!!!
.I had updated to debian 10 and omv 4, but unfortunately found no solution on the www.I kept getting smb error messages and every copy process was canceled after a few MB and the memory was full.

Our Workaround:
Create a File

/etc/sysctl.d/99-vm.conf

with the following content

vm.min_free_kbytes=8192

After that, the memory of the WDMC Gen2 was no longer full, even after a restart, and all write and copy processes ran without errors !!

Hth

Hi,
New here and this is a BIG thread. I want to install debian on My Cloud EX2 and I found some instructions about installing .bin files but when I download these files:
CleanDebian-Jessie.tgz
CleanDebian-Wheezy-en_US.7z
I dont see any .bin files. Can someone please link to the setup instructions for these?

Hi,Can anybody please tell me instructions to install DSM on my cloud gen 1 when HDD is connected to pc having linux.TIA.

https://fox-exe.ru/WDMyCloud/WDMyCloud-Mirror/

Ex2= MIrror there the same/

I would go with DSM Personally. I have a EX2 and Run DSM its smooth and very very nice… The interface is golden tons of apps… ETC…

https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen1/Synology_DSM/

@Fox_exe I tried my best until now, but I´m completely lost with compiling my own kernel.
I downloaded your sources, installed make and all the other tools, but it just won´t compile…
Can you give me a little help?

What you need help with?Shoot me a PM with your email I will contact you if you would like.

I am trying to install DSM 5 to WD MyCloud Gen1.

However I am stuck on the first step. I got green light on my WDMC (using the boot recovery from HDD method), however, I do not understand the part for Start_DHCP and Start_TFTP, which I am not able to connect via telnet. It says connection refused. Also not able to get to recovery websites. i.e. mycloud.local
Can anyone provide me tips on how to connect via telnet for DSM installation?

Thanks

Has anyone managed to compile and use 5.5.0+ kernel? I compiled it successfully – I have both uImage and lib/modules/5.5.0+ directory, but I can’t get it to work.

Hello everybody, I have a little problem, and I hope it is a small problem. I cannot install Openmediavault on my WD My Cloud Ex2 Ultra. I have installed fresh Debian, and now I get this message, help please:

root@wdmc:~# apt-get install openmediavault
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
openmediavault : Depends: php5-fpm but it is not installable
Depends: php5-cgi but it is not installable
Depends: php5-cli (>= 5.6) but it is not installable
Depends: php5-pam but it is not going to be installed
Depends: openssh-blacklist-extra but it is not installable
Depends: monit (>= 5.4) but it is not installable
E: Unable to correct problems, you have held broken packages.

Thank you again

I see no replay… :frowning:
what about this:
Reading package lists… Done
W: GPG error: http://packages.openmediavault.org/public erasmus InRelease: The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY 7E7A6C592EF35D13 NO_PUBKEY 24863F0C716B980B
W: The repository ‘http://packages.openmediavault.org/public erasmus InRelease’ is not signed.
N: Data from such a repository can’t be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.

any help there?

PLEASE

root@wdmc:~# apt-get update
root@wdmc:~# apt-get install --yes apt-transport-https

root@wdmc:~# cat <<EOF >> /etc/apt/sources.list.d/openmediavault.list
deb https://packages.openmediavault.org/public arrakis main
EOF

root@wdmc:~# export LANG=C
root@wdmc:~# export DEBIAN_FRONTEND=noninteractive
root@wdmc:~# export APT_LISTCHANGES_FRONTEND=none
root@wdmc:~# apt-get update
root@wdmc:~# apt-get --allow-unauthenticated install openmediavault-keyring
root@wdmc:~# apt-get update
root@wdmc:~# apt-get --yes --auto-remove --show-upgraded \
--allow-downgrades --allow-change-held-packages \
--no-install-recommends \
--option Dpkg::Options::="--force-confdef" \
--option DPkg::Options::="--force-confold" \
install postfix openmediavault

root@wdmc:~# omv-initsystem

Hello !
Thank you for your works :slight_smile:

I wish have help, i put Debian on my WDMC Ex2 Ultra but i would put DSM now and i don’t know how to rollback, do you know how to do it ?

EDIT: I have an WDMC Ex2 Ultra.

Thank you !

EDIT 03/11: I found a solution, it will be great to put it on the txt file on for exe’s website.

1. Download the original files (uRamdisk and uImage) : https://fox-exe.ru/WDMyCloud/WDMyCloud-Mirror-Gen2/Original/
2.
dd if=/dev/zero of=/dev/mtdblock1
dd if=/dev/zero of=/dev/mtdblock2
dd if=uImage of=/dev/mtdblock1
dd if=uRamdisk of=/dev/mtdblock2

Hope this will help you !

is there a way faster way to reinstall DSM 5.2 on a gen1 my cloud or i will need to follow the “Replace HDD and install the original_v04.01.02-417.tar.gz and upgrade to DSM ? where can i edit to change the MAC address/Model Name and the serial number ?

tar xvfz dsm-rootfs.tgz -C /tmp/hdd1
dd if=dsm-kernel.img of=/dev/sda4
dd if=dsm-bootconfig.env of=/dev/sda7

Hello,

I have a wd mycloud gen2

After doing this https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen2/_Unbricking_en.txt it stays at 0 procent. I found another way to get the mycloud running but when i try to run dsm on it it won’t work.
I try several things but after install DSM-wdmc-gen2-8451.pat it won’t reboot anymore and the red led keeps blinking. Any suggestions??

Please help me out

any chance u can tell me how to change the MAC address, Model Name and Serial number ?

Thank you very much for all the work @Fox_exe
I’m trying to install on a EX2 Ultra, but after reboot and partitions steps,
it can’t connect to internet so when I try to wget the debian stretch file it can’t download.
It says:
wget: bad address ‘fox-exe.ru
I tried to ping websites and it’s offline indeed (but ethernet is on the router and I’m connected through Telnet)
Any suggestion on how to upload the files manually?
Or advices to succeed to connect to internet?