Clean OS (Debian), OpenMediaVault and other "firmwares"

Yes. (WDMC Gen2 in my terminology).

Hello Fox,

I have been following your posts in WD forum for quite sometime now and found your explanations much easier.

I would like to seek your guidance to host a web server with few websites running.

From past 3 months I was spending time learning Linux technology as I wanted to setup a mini scale web server hosting couple of websites only, as such I learnt Fedora and Apache.

Eventually, I purchased WD My Cloud v2.21.111 and was under the impression that I could implement the webserver and pages…but to my distress I did not even understand this infrastructure; however, I have understood from all these posts that there is a possibility.

Hence, would you please guide or point me to a direction to know how can I implement this - need Apache + Joomla or Drupal + OwnCloud.


Hi Fox,

thanks for your guide ,my WDMC Gen2 installed OMV
but now the OMV can not add a shared folder for instance, I have no device listed. It shows blank.
check the OMV file system . the /dev/sda2 automatic mouted , can not umount and delete

Need unmount data volume in fstab and mount it from WebGui (This add’s new, correct, record to fstab and omv database)

I get this error while trying to run apt-get command via chroot - bash-4.3

Error Message: apt-get: error while loading shared libraries: cannot open shared object file: No such file or directory.

Hi Fox!

Thanks for your effort in the first place. I managed to get DSM installed and running for now… but i have a little problem, if i reboot, it only will reboot if i put the usb stick in for 10 seconds while booting. otherwise it will give me a red light.

i tried to create a boot folder in the / directory and put the same uImage and uRamdisk in it that i have on the usb… but didnt work. is there any way to get this fixed? thanks!

Need put this files to 3rd partition (/dev/sda3, /boot folder). sda3 mounted as /volume1 (if I am not mistaken).

yeah that did the trick. shame on me for not trying this ^^

i got one more for you haha, i managed to setup a cronjob that mounts the sda3 on reboot… but here it comes, after i reboot, my shares in the filestation disapear. you have any idea whats wrong here?

I installed clean Debian and OMV on my myCloud Gen1. It works perfect.
Thanks a lot to @Fox_exe

The only issue I’m facing to, is that the disc never spins down. I had a look with iotop on that. My guess is that OMV writes to the system disk too much to spin down.

Can anyone confirm that? Or was anyony able to spin down the disc with OMV?




First of all thanks for your work! I’m running CleanOS with OMV on one of my WD MyCloud 1st Gen. 3TB. Today I tried to install it on my second MyCloud (same config as the first). But something went wrong :frowning2:

The LED stayed White for more than one hour and nothing happened. I tried reading the disk on ubuntu but I also failed at this one.
So I erased all partitions and followed the steps for replacing the HDD.
First parted states that he can’t
mkpart primary 4824M 4826M
and gives me an option to place it in another sector range.
mkpart primary 4826M 4828M
I get an performance warning. Also when running
mdadm -A /dev/md0 /dev/sdb1 /dev/sdb2
I get
“no recognizable superblock on / dev / sdb1”

So I went on with:
mdadm --assemble /dev/md0 /dev/sdb1
mdadm --add /dev/md0 /dev/sdb1

Afterwards everything went smooth until:
touch /mnt/hdd/etc/.fresh_install

Here i get:
“nothing to touch”

Reassembling the NAS and starting it returned a red LED.

So I think I’m at a point where my only option is to restoring via HDD.
But what am I doing wrong?

Thanks :slight_smile:


I finally succeeded by downloading a “virgin” image of the WD Mycloud 2TB. But I’m still convinced that i was failing in the first place because of the sector size. After I now successfully installed clean debian I looked at parted -l and also here it says logical = 512, physical = 4096.
So since it’s now working, I would say never mind :smiley:

For WD MyCloud Gen2 now available Synology DSM v6.0.2-8451!

  • Almost all works perfect.
  • Blue led = standbuy, Red = Alarm/Error, Green (cyan/ = Disk activity
  • Awesome network speed (samba) - 100-110 MBps! (Full Gygabyte/s!)
  • Working Autoupdate (Autoupdate firmware from my website).


  • USB works, but DSM can’t see usb drives (But in SSH all accessable / can be mounted). Fix: mount usb drive via SSH to any empty folder in already shared folders. If someone find why this happends - tell me please.
  • If HDD less than 4TB - install from webgui format HDD to MBR. Its not supported by bootloader and device can’t boot. Fix: Use parted (from debian fw) and reformat disk to GPT, then recreate partitions with same size (run fsck for part. 1 and 3 just in case)

Hello Fox!
Thanks for your effort.
BTW I have installed debian on MC gen2, but it seems it doesn’t detect usb.
Does usb work on your debian?

Need enable USB power: Add this to /etc/rc

echo 13 > /sys/class/gpio/export echo out > /sys/class/gpio/gpio13/direction echo 1 > /sys/class/gpio/gpio13/value

Thanks for the reply.
Still All I see through ‘fdisk -l’ is HDD partitions. I did run those commands and it shows me ‘-bash: echo: write error: Device or resource busy’, so I guess the commands already have been executed.
What should I do? Thank you.

Ok, I’ve read through this and related threads several times now, and I’m still not sure what the best way to proceed is.

I have the EX2 (which I understand is the same as the gen 1 mirror).

Do I start with the Autoinstaller that’s in /WDMyCloud/WDMyCloud-Gen1/Autoinstall ?? Or is there some other way to do this, without bricking the machine from the getgo?

Can you please direct me to a tutorial or a post which more or less describes the sequence of steps to go through, as some appear to be outdated, or relate to other hardware?

Finally, what’s “WDMyCloudEX4_Debian_8.0-1.bin” in gdrive under /WDMyCloud/WDMyCloud-Ex2/Apps ? In fact, what “.bin” format are all the .bin files in?

Many thanks in advance!!!

Hi Fox_exe,

I got your new 8451 DSM files “DSM-wdmc-gen2-8451.pat” & “wd-to-dsm-8451.bin” from your ftp,

I have tried to upload the bin file in recovery mode but fail…Could you let me know how to use the bin file and boot to DSM via webinstaller? Thank you so much!!

.bin (firmware file for install via WD webgui) not working (idk why).
Test it later. Use “hand” method - replace files in /boot/boot folder.
But here few bug’s:

  • If HDD less that 2TB - dsm format it as MBR (But need GPT). So, need reformat hdd to GPT (Use debian image for that, or your PC)
  • Once i have strange bug: /boot folder on 3rd partition not seen by bootloader, but exist on disk. Just recreate this folder (Save files inside!). Use debian for that, or telnet access when DSM in recovery mode.

Hello Fox_exe,

Many thanks for your reply, replace “files” in /boot/boot folder, …which files? is it extracted from “”?
let say…forget the bin file, it useless at the moment?