CIFS Authentication for user [my email address] has failed

I’m running Windows 10 and my WDMyCloudMirror Gen2 is at firmware version 2.31.149. I was using Excel on my iPad and had updated a spreadsheet on my WDMyCloudMirror. When I attempted to save the updates, I received a message stating the file couldn’t be opened. This is the first time I tried to use Excel from my iPad, and the spreadsheet was located in Public\Shared Documents, which I didn’t think needed authentication because it is not a private share. I checked the log on the MyCloudMirror and found the following message for the time when I attempted to do the save.
CIFS: Authentication for user [my email address] has failed.

I also saw the message for days where I didn’t use the iPad to access the MyCloudMirror, so they may be related to when I access the MyCloudMirror using my PC. The only user defined on the MyCloudMirror is admin. I tried to define a user using my email address, but it is too long to use. I think my email address is being used in the message because it is my Windows 10 login username. Any help would be appreciated.

Windows 10 has what is called an “online account” which uses your email address. The online account used Active Directory aka Samba.

  • create a Local Account on Windows 10
  • login using the Local Account
  • when accessing the My Cloud, enter the My Cloud “admin” username and it’s password

Thanks for the quick reply. Changing to a Local Account appears to have fixed the error messages. After changing to the Local Account I accessed many files from different shares. I didn’t have to enter the My Cloud “admin” username and password for any of the accesses. I checked the log and didn’t have any of the CIFS messages for the remainder of the day yesterday. I did receive a CIFS message about 7 minutes prior to starting this reply. It is puzzling because I wasn’t using my PC or iPad at that time. I had been using my iPhone, but only for email and browsing.

This also partially solved my Excel mobile problem when saving a spreadsheet to the My Cloud. I’m able to save the spreadsheet to the My Cloud, but there is also an option to “Save a Copy” with a new name. “Save a Copy” still gets an error stating the file can’t be opened, and there are no messages in the log for the times I’ve tried it. I’m not too concerned about the “Save a Copy” option, as I only wanted the normal save to work.

Thanks for your help.

The log still shows the CIFS message with my email address at times when I’m not using my PC. I’m still logged in using the Local Account.

This morning I accessed a file in the Public\Shared Documents share on the My Cloud using my wife’s PC and her microsoft account, which has a different email than mine. I saw the CIFS message with my email as the user. I recalled that my email address is the email address for the admin account. Maybe the messages are occurring because of something the admin account is doing. I tried to clear the email address from the admin account and couldn’t do it. Is there a way to remove the email address from the admin account?