Choppy Playback Streaming Movies via Sony BDP-S370/BX37 Blu Ray or Widows Media Player

I had previously reported / thought the issue was with my Blu Ray player…after tesing with W7 Media Player, and seeing the same problems … am reposting

set up:

4 TB

Firmware is current

Verzion FiOs Router, Actiontec, 100 Mbps Firmware is up to date

No changes made to the Router …any suggestions?

Twonky is 7.2

Twonky does not list my model Sony, so I chose “generic” Sony Blu-Ray

MyCloud, W7 Laptop, Sony all on 100 Mbps Ethernet

Playback on W7 laptop using VLC / Windows Media Player on PC is fine

Choppy …on both the Sony and the W7 laptop with Windows Media Player.

Is there a format (MKS vs AVI vs ??) that is less susceptible? I tried a couple of formats, but no luck

Suggestions ?

Devices might be underpowered for streaming HD content. 

Can you explain “underpowered”, the files “stream” ok to my PC using File —> Open and  VLC …wired or wireless.

And the same file plays A-OK from the Sony when put on a USB and plugged in…

Oh didnt read through ur entire post.  VLC and WMP might be using different codecs as VLC has it built in and WMP you’d have to install a bunch of different codecs to get HD content to play nicely on your systems. For the sony, what wireless connection are you getting? have you tried wired?

as stated, all components are wired 100 Mbps…

given that both DLNA clients (sony and W7) have the same issue…and that the file plays GREAT from VLC or via usb on Sony…it sure looks like the WD MyCloud is having an issue.