Choppy playback on WD live TV hub

So its all worked well and smooth until now. Regular AVI format videos are really choppy and hard to watch but MKV files seem to work just fine… I cant seem to figure out whats wrong with this device all of a sudden… It did appear to all start happening after the most recent update but i have rolled back to the previous and it did not help. Also tried the reset button under the machine and still choppy… Anyone have any ideas ? im stumped… oh and if it helps its being run on a 42 inch sony Bravia lcd via HDMI… sound through tv nothing special like a reciever or anything…

Any help would be greatly appreciated…


Post the media info of  one of your movies:

Also, your movies, are you streaming them from your network or from a USB drive connected to the WD TV?

Both ive tried playing movies from the local 1TB WD hub drive and my wireless connection and both are choppy.

 Oh and btw these are all .avi files that played Flawlessly prior to this issue.




So here is what that program info of 1 of the files said

Format                           : AVI
Format/Info                      : Audio Video Interleave
File size                        : 700 MiB
Duration                         : 1h 30mn
Overall bit rate mode            : Variable
Overall bit rate                 : 1 076 Kbps
Writing application              : VirtualDubMod (build 2540/release)
Writing library                  : VirtualDubMod build 2540/release

ID                               : 0
Format                           : MPEG-4 Visual
Format profile                   : Advanced Simple@L5
Format settings, BVOP            : 2
Format settings, QPel            : No
Format settings, GMC             : No warppoints
Format settings, Matrix          : Default (H.263)
Codec ID                         : XVID
Codec ID/Hint                    : XviD
Duration                         : 1h 30mn
Bit rate                         : 935 Kbps
Width                            : 592 pixels
Height                           : 320 pixels
Display aspect ratio             : 1.850
Frame rate                       : 25.000 fps
Color space                      : YUV
Chroma subsampling               : 4:2:0
Bit depth                        : 8 bits
Scan type                        : Progressive
Compression mode                 : Lossy
Bits/(Pixel*Frame)               : 0.197
Stream size                      : 608 MiB (87%)
Writing library                  : XviD 1.2.1 (UTC 2008-12-04)

ID                               : 1
Format                           : MPEG Audio
Format version                   : Version 1
Format profile                   : Layer 3
Mode                             : Joint stereo
Mode extension                   : MS Stereo
Codec ID                         : 55
Codec ID/Hint                    : MP3
Duration                         : 1h 30mn
Bit rate mode                    : Variable
Bit rate                         : 128 Kbps
Channel(s)                       : 2 channels
Sampling rate                    : 48.0 KHz
Compression mode                 : Lossy
Stream size                      : 83.6 MiB (12%)
Alignment                        : Aligned on interleaves
Interleave, duration             : 24 ms (0.60 video frame)
Interleave, preload duration     : 143 ms
Writing library                  : LAME3.90.
Encoding settings                : -m j -V 4 -q 2 -lowpass 17.6 --abr 128

Thanks in advance for any help,


Im thinking about just buying another and just returning this one in its box… Nothing seems to fix the problem… I’m pulling my hair out… 200 bucks and it just took a poop i think…


The thing that gets me is that it plays all MKV Files Flawlessly… usually they would be the problem not an .avi file…



Have you tried the Auto Detect Framerate option in the Resolution Settings on the Live Hub ?

(Select ‘Auto’ for all Settings and it will eventually ask wether you wish to enable this)

1 Like

I recently received a WD Live TV plus player for Christmas and experienced the same problem. Networked the player so I could view movies from my hard drive.  Mkv movies would start fine but a minute into the movie it became choppy with no sound. Information I got from this forum cleared the problem up. This is what I did:

 1. Set the unit back to original firmware(reset button on side/ also in set up I reverted back to factory settings)

  1. Changed Video resolution from auto to manual (1080/60)