Choppy audio with Netflix

I’m new to this board - I running WD TV Live Plus; at first, Netflix worked great. Over the last couple of weeks, though, the audio will drop for a second or two about every 15-20 seconds. Needless to say, this is annoying. I’m running the signal via HDMI - any thoughts on what might be happening? I’ve attempted to contact Netflix on the issue, to no avail.

Any help/guidance you can provide will be greatly appreciated. Thanks -


Hi dude, what have you tried so far? o.o

A quick update - I did the factory reset on the box and re-activated the device through Netflix, and all is now working. Seems to be a convoluted solution, but at least it’s good - for now.

Thanks -


I am having the same problem. 

I have a WDTV Live Plus with a Linksys WGA600N dual band gaming adapter.

I have done a few things and am still having the issue.  It is not a Netflix issue since I can jump on my laptop right as its doing it and watch with no errors.

What I have done so far…

1-Reverted to previous updates. Both did not work.

2-Checked the HDMI cable.  Cable is good. 

3-Restarted my game adapter.  That  didn’t help either.

4-Unplug my WDTV for a minute and replugged.  That did not work.

5-Press the reset button.  Didn’t help

6-Reset via the menu.  Didn’t help

I am going to try to go directly into my router and not the gameport and see if that works. 

I just tried using a hard wire straight into my router and I am still getting the choppy audio when streaming Netflix.  It comes and goes and is not consistant.  I played the same episode of a series and randomely get the choppy audio. 

Have you tried dis-abling and re-authenticating Netflix? I’m not sure how to do that (I had to do it once I reverted everything back to factory defaults). You might try that.

Good luck - I know how frustrating this can be.


Yes.  Tried that.  When you resent the unit you have to reactivate your Netflix account.  Still does it.  VERY FRUSTRATING!  The main reason I purchased this was to watch Netflix.  Just to recap…

I have reseted the device

After reset I have reactivated my Netflix account.

I have tried two older versions of the firmware.

I have tried and left it at the latest firmware.

It is not happening as much but still does it.  It is rare that I can watch for a few hours with out a glipping or a choppy sound drop. 

Ok so I have since given up trying to watch Netflix on this unit.  I am going to try to exchange it for another one if the store will do so after a few months of use.  Is WD at least working on this issue in a firmware update???

This will be my last post on this problem.  I have solved it with great satisfaction.  I went back to the store… returned the unit and since they didn’t have anymore in stock I picked up a Seagate GoFlex TV and couldnt be happier.  The picture is sharper.  The interface is better and no choppy audio in Netflix.  Thanks WD.