Chmod: DataVolume: Read-only file system

I upgraded the firmware to 2.2.91 but after that, I’m not able to write / delete files to folders on DataVolume. After reading many posts here, I try to ssh into it and chmod on DataVolume,  however got error below :

/ $ chmod 777 DataVolume
chmod: DataVolume: Read-only file system

It seems the DataVolume becomes read-only and I’ve no way to change it back to writeable on both ssh and web interface.

Anyone has idea how can get this fix without rebuild the volume or restor factory default?

Much appreciate.

Thanks for the post it sounds like a similar post reported on this forum. So everyone on the forum can better assist you is it possible to take a screen shot of the exact error message? It would be greatly appreciated.

Have you tried chmod as superuser, usually

su chmod 777 -R

I think the default password is welc0me, but don’t quote me because I got rid oof my ShareSpace some time ago.

Thank you all your comments.  Attached is the screen shot.  Pls point me if where I am wrong.  Thanks.

wd_read_only_file_system.JPG

Try su on its own to log in, as in

su

then

chmod 777 -R

ED: Although I see that you seem to have done that… sorry - can you confirm that after you type su and [ENTER] into the shell, and then the password at the prompt there are no errors? After all, as superuser there should be nothing in your way to chmod files & directories.

Hi GuiGuy,

Yes, I try su and then password without any error.  As screen shot, my a/c is root after su, but still no luck and get the Read-only error when chmod.

Thx.

You can try this and see if it works.

mount -o remount /

Something about how the root system was initially mounted as read-only is the cause. That’s whay chmod doesn’t work. Was once a Linux kernel issue.

NOTE: YMMV

–dennis

One more thing. That it is mounted in read-only may mean you have a filesystem problem.

–dennis

dngovoni wrote:

One more thing. That it is mounted in read-only may mean you have a filesystem problem.

 

–dennis

That’s the only explanation I can think of as well. As su, if the HDD and file system is OK, there should be full control.

One other scenario might be that the HDD are formatted as NTFS.  I’ve had that on 'nix boxes. In fact, there can be all sorts of permission problems accessing NTFS formatted HHDs from Linux, especially if there’s a WIn7 PC in the mix.

Cheers