Changing the format of a file


#1

I have an mkv file (x.264) with DTS that won’t play. WD suggests changing the format of the file to one that is compatible, but it is one the list of compatible video and audio formats. It even plays the sample of the movie which is in the exact same format and 25+ other Blu-Rays in the exact same format. The movie plays fine on VLC through my computer.

Any suggestions to troubleshoot? Thanks,


#2

Did you change any of the option when transcoding this to mkv versus your other files?

Try this program (Sourceforge):

Mediainfo

See if there are any differences in that one trouble file versus your others, that may be the difference…


#3

if i had this problem, first thing i would do is to remux the audio/video into a new mkv container and see if it plays.

use mkvtoolnix—mmg.exe

add your existing mkv file, choose a diff name/location and start it


#4

Registered just to say this.

Fugger - you’re a genius. This tiny piece of advice solved an ongoing issue I had with some older, downloaded .MKV rips not playing. Went to blue loading ring, then black screen, then nothing. After playing one of these files I couldn’t play anything else until a full power cycle. Seems to be related to versions of MKVMerge < Jan/2008.

I’d tried -everything- else I could think of - all official firmwares, all homebrew firmwares, playing from USB, playing from network share, playing from DLNA server. Nothing worked.

A simple re-mux with a recent version of MKVMerge solved the problem instantly.

Thank you very much :slight_smile: