Changing Hard Drive Size in EX2

Hi,

I originally implemented the EX2 with 1TB drives.  I’m now replacing them with 2 X 4TB drives.  After placing the 4TB drive in one of the slots, I see the Raid-1 was rebuilt automatically.  On the dashboard, it now shows the new 4TB as a 1TB.  How can I try to regain the lost space?  I tried GParted without success. 

At this time my plan is to reformat the 4TB drive and place it into the EX2 case.  I expect the EX2 to prepare the drive in a way to give me the full available space of a 4TB drive.   I’ll place the old 1TB drive into an external USB case and copy the files over to the EX2 with the 4TB drive.   The only problem I have with this plan is that my Win 7 PC wants to reformat the 1TB drive.  I can’t seem to locate the files I need.  Are these files hardware encrypted by the EX2?  Any suggestion on how to recover these files?

Thanks in advance!

1 Like

Caveat: I am not a doctor, don’t do anything listed below, blah blah.

Ok, you’ve done the hard part - dropping in the new 4tb drive and letting it build the array. Congrats! So, in your raid setup, it can be only as large as the biggest disc - 4TB now equals 1TB. Here’s what I would do…

Lazy man’s way:

Step 1)  Stick the 1TB you already pulled out in a USB case, like you planned - or just plug it in to your computer, format, and do a network copy. Gonna be slow either way, so just go for it.

Step 2) Take all the discs out of the raid. Keep the original 1TB just in case something goes wrong, etc.

Step 3) Wipe the 2 x 4TB drives and reinstall. It should freak out, build a new array, etc.

Step 4) ???

Step 5) Profit!

Hope it works for you. I know one of these guys probably has a better solution to where you resize the partition on the 4TB (now 1TB) drive, take out the other 1TB drive, insert both 4TB drives and let it clone over to the fresh disc - but since I haven’t tried it, you’d be on your own.

Could work, though. Anybody else chime in? I’ve been too lazy to try it myself.

1 Like

I don’t see anywhere where MowerPartsGroup addressed the original poster’s main issue about copying the data already on her 1TB drive.

So  JENHENWD, the reason why you can’t read any data on the 1TB drives is because the drives are in Linux ext4 format, which Windows cannot read natively. You need a computer that can read ext4 format either natively like another Linux computer OR install a third party Linux format driver on Windows and then plug in the 1TB drive from an USB case or a drive dock. There are several out there - some paid and some free. I only have used this free one with perfect results in the past but YMMV ->  http://www.paragon-software.com/home/extfs-windows/

Once you have installed that software, you can then connect the 1TB drive to Windows and copy your files to the Windows computer or to the EX2.

If this answer helps you or at least clarifies some of your questions, please click the star under my username to the left of this post to give me a kudo.

1 Like

Hi MowerPartsGroup and Cybernut1,

Thank you both for taking the time to provide some helpful information.  I searched further but just could not find an easy solution to enlarge the new 4TB drive from the formatted 1TB size.

MowerPartsGroup, I currently have the 1TB drive in an external USB case.  I reformattted the 4TB drive back to raw and allowed the EX2 to prepare the drive.  I now have the full 4TB space in slot 1.  After completing the transfer, I’ll drop in the second 4TB drive and have the EX2 rebuild Raid-1.  Hope this plan works.  I hate to redo anymore transfer as I am only transferring at a rate of 3.78MB/second.  I can’t believe how slow this process is.

Cybernut1, I’ll look into the program you suggested.  Your information about this being a Linux device clarifies everything (I’m not terribly savvy with software/operating systems).  This is something that WD should have a built in application for as I’m sure I’m not the first that needs to pull data off a drive during upgrades.

Have a wonderful Holiday to you both and thanks for taking the time to help a fellow owner!

1 Like