Changed Book Drive ownership in Windows 7, now I can't access anything on the drive

I own a WD Book Drive (2Tb), backing up a Win 7 pro PC.

Of course, I have my password for logging into WD Smartware. I thought by asigning additional permission restrictions, it would keep others from being able to see my files. there is no network per se, just the PC (C:) with the WD external (iF:) containing files.

After accessing the WD smartware, I rt. clicked on the F: icon on the top page of the WD software window. That gave me a small box with 3 options - one of which was properties. I later discovered that this was Win 7’s utility, not WD.

I selected properties, and checked the permissions. they looked okay, but I just HAD to click on ‘advanced’, which took me to another window with a few tabs along the top (audit, owner, etc.). I selected ‘owner’ and discovered that there was no owner listed. this seemed odd to me - shouldn’t I be listed as the owner? or, if not my login (marks-PC), then surely ‘Administrator’, right?

Anyway, the 2 user names (marks-PC and Admin) were listed as options, so I selected Marks-PC, and clicked apply. a window opened up, with directory/file pathnames scanning by rapidly.

After this was done, it told me that I needed to assign privledges. I clicked okay, which took me back to the permissions security page. These were already set (as far as I could tell) so I just exited all the way out.

When I tried to reopen WD smartware, I got a ‘F: access denied- you must format this drive before you can use it’ or something like that.

Very distressing!

I shut down everything, rebooted PC, logged into WDsmartware. I tried changing ownership to ‘administrator’, and the whole file structure scanning took place again, but same result… I can’t access a single file.

windows properties for the drive show that it is ‘0 bytes’, yet I can see that there is about 1T of data stored when I access the drive via WD smartware.

At least I know that the files are there. Question is, how do I fix this? Can I just go back to no specified owner?


Changing the permission to the files is not going to show a message to format the files, this usually happens when the data is corrupted, try scanning the hard drive with a data recovery program to see if you can access your files. Using Google you can find several options.