Change port listening assignment

I have FeaturesPacks AccessBook installed on my MBL.  I also have ownCloud installed.  Both processes listen on port 443.  I need to change either of them to listen on another port.  Can someome please tell me how?  I’ve tried a few times in the www-nas files but it always gets over-written when apache restarts.


See if the following link helps:

I forgot that i had solved this problem a few years ago.

If your router does not allow for incoming port redirects to other ports, then there is another solution. in etc/apache2/sites-available, copy the WWW-private file, and rename it. Then open the copy and edit it so that it is listening on another port (perhaps 449). Save and then make a symlink in etc/apache2/sites-enabled . Then restart apache.