Caviar Green 3TB only shows 746GB?

Running Windows 7 Home Premium Service Pack 1 on 32-bit Operating System.  Why is 3TB Disc only showing less than 1/3 of total space.

I found the solution elsewhere on the fourm.  It is listed below.  It was a bit scary installing an update to my chipset but it worked perfectly.  My 3TB disc is now showing capacity at 2.72TB.  Much better that the 746GB before the fix.

Re: Windows 7 64-bit won’t show full size 3TB of WD30EZRX

If you have Intel chipset you have to download lates version of chipset.

My chipset is Intel Q57

In my case helped newest chipset version

I had the same problem, Intel has a program to fix their chipset, if  you don’t have one your out of luck, my chipset was Nvidia and I tried for a whole day updating the bios with Asus updates did not work made things worse, then finally I tried Nvidia updates and it work like a dream, so if you need to update your chipset go right the the chipset manufacturer for your update, hope this helps someone.

After reading my post it didn’t read right, it should have read the updates wear done through Asus because it was an Asus motherboard