Caviar Green 2TB installation issues

Hi, I’m not sure if this is the right place to ask about this … : I just bought a 2TB Caviar Green ( WD20EARS ), but I’m having troubles installing it on my ( quite old ) PC. I have an Asus A7N8X-E Deluxe Motherboard with a Silicon Image Sata Raid Controller onboard ( it’s a sata 1 controller ), I fixed the HD in place and connected it to motherboard and power, I’ve set jumpers 5 & 6 on the HD to force 1.5 gbit transfer rate. When the pc starts up, the bios screen appears, everything looks fine, then the sata/raid controller configuration screen appears, it detects the HD ( well, at least it reads model number correctly ) and then it FREEZES. I’ve tryed pressing F4 and/or CTRL+S ( as shown on screen ) to open the configuration menu, but nothing happens. Also, about the cable I’m using … I have 2 different cables ( that came with my motherboard ), very similar, they both mount and give the same result ( above ). I’m not sure which one I’m supposed to use, what’s the difference? Do I need to use a Sata 2 cable? Any other ideas? Any help will be greatly appreciated.

I’ve apparently solved the problem by installing a modified motherboard bios, containing an updated driver for the integrated sata controller. I’m formatting the HD now, we will see what happens … I’ve found step-by-step instructions here: Be aware, only use those instructions for Asus A7N8X-E Deluxe Motherboards. Also, use at your own risk ( that is, if you mess up you can probably trow your motherboard into the trash bin )

yep, it works just fine.