Caviar Green 1.5TB drives - problem with new firmware


#1

Synology support the WD15EADS FW rev 00R6B0.  They do not support the same drive with rev 00P8B0.  Sadly the only FW version available in the UK at present.  What is the likelihood of a FW update to fix the issue?  Just bought two that I thought were supported drives (I checked) but since they arrived they have been spurned by Synology and exhibit the very problems they describe. . . 

See ; Not supported 

 and  http://forum.synology.com/enu/viewforum.php?f=151

Hope you can help.


#2

Greetings,

Firmware updates are not usually released to resolve compatibility issues with one piece of hardware.  This is true of any drive manufacturer, and not just WD.  I would not expect a firmware update/revision unless an exorbitant number of compatibility issues were found or reported. 


#3

Actually alot of people has theese problems

I have the same problem

the WD15EADS-00P8B0 is very slow and makes my system freeze for a few second  every few minutes and the drive speed is sometimes as low as <1 MB/s and has LCC problems

the 3 WDxxEADS-00R6B0 that i have is running perfectly and fast and without LCC problems

this is just a few threads that i found

Western Digital Green Drives Slowness Room

http://forum.synology.com/enu/viewforum.php?f=151

http://ubuntuforums.org/showthread.php?t=1297342

http://forum.qnap.com/viewtopic.php?f=182&t=14273

http://www.silentpcreview.com/forums/viewtopic.php?t=51401&postdays=0&postorder=asc&start=0&sid=edf3bd13afe157e255f3b651bf21484e

http://www.linuxquestions.org/questions/linux-hardware-18/western-digital-caviar-green-1tb-wd10eads-load-cycle-

count-issues-746049/

http://bbs.archlinux.org/viewtopic.php?id=73573


#4

Compatibility issues can and should be reported directly to the hardware manufacturer.  Email Support directly.  This will allow them to track of the number of reported cases.


#5

@ricochet Who are you?  Do you work for WDC or is this some independent forum?  Who are you suggesting we contact; WDC or (Synology in my case)?

If posting what I have and the response are not direct questions to WDC perhaps you could explain why not?


#6

Greetings,

I am not a WD employee.   Just an end user like yourself. My background is in Technical Support, Quality Assurance and System Administration.  I was very active on these forums from 2003-2008.  The forums were taken down early in 2008 and were re-implemented recently.  The Service and Support forums were not moderated previously.  Now, there is moderator presence.

I suggested that you contact WD support, since any product enhancements or firmware updates would come from them.  Granted since the forums are moderated now, I’d imagine that tech support would be made aware if a high number of  compatibility issues were reported. 

I’m sure these issues, bugs and feature requests are tracked and discussed by customer service, product development, and tech support.  Reporting your issue directly helps in this process.  :wink:


#7

I Already contacted WD but the claims that there is no problem and the synology is to blame

but that is not the case

and the supporter I talked to said that I shouldt count on any future firmware updates to fix the problem

so basically I am stuck with a worthless HDD that slows my system down witch I think is weird because the tree other WDD Green  is working great :frowning:


#8

I hear you. I visited the synology forums and reviewed the list of compatible drives.  I’m sure they are doing their best to update that list as more drives are tested.  Hurts when you’ve invested in something that doesn’t.


#9

yes but the thing is most older WD green works but the new ones does not and they are all called WD15EADS and and the stores never writes the suffix lik 00P8B0 or 00R6B0

so basically the only thing your can do is buy another brand


#10

Ricochet,

thanks for your response.  Apologies for my rather pithy inquisitorial style.   I’m glad to hear this is likely to be being watched.  Sadly the response Wolf got doesn’t bode well, but I’ll have a go.

I’m quite sure that in the depths of both WD, Synology and other companies there are people who know exactly what the problem is. A little openness from all manufacturers might assist things.

Investments like this are not made casually and when people check compatibility only to discover the disks they have bought do not work its galling.


#11

I have the same problem on my Popcorn Hour A110

Very annoying when it takes hours to transfer something that should go on 10minutes. Freezes and the speed drops to under 1MB/sec all the time.

Also have the 00P8B0 -version of the disk.

If there isnt going to be any fix for this soon, I guess i have to buy another disk.

Wont buy anymore WD disks, thats for sure…

/ Anton


#12

I’ve noted similar problems with my new ED15EARS drives.  I’m still attempting to track down if the “advanced format” is causing me issues or not.  In one machine, the drives seem to move fine individually, getting 76MB/s transfer rates.  in another, they slow down to about ~10MB/s.  These aren’t the painfully slow speeds that others are describing, but I’m wondering if they might be related.  The 64k buffer of the EARS series might stave off some of the problem, but not all.

I disabled the power saving features of Win7 (i.e.  Disk sleep after 20 minutes) though it seems odd that would cause any problems immediately.  And…if the drive is transfering data…then it wouldn’t exactly be idle.  That could be a problem with either the HDD reporting or windows software detecting.

Also, since it is an advanced format drive, I was concerned that perhaps the factory “alignment” of the sectors wasn’t done correctly.  I’ll have to research the WD tool to verify, but it would be nice if Win7 could tell you that outright.

The only other obvious differencse are that the machine which is slower is an ICH9R system running 64bit Win7, while the “fast” machine is ICH10R system running 32bit Win7.

Has anyone run the alignment utility on a newer OS to see if everything is in order?

EDIT:

After running a few more tests, I can confirm that the problem (for me) occurs when placing the WD15EARS drives in any form of RAID, be it via the Intel BIOS or within windows.  I’m sure someone could explain the technical reasons for this.  (I thought I saw somewhere a post that mentions “green” drives running at unique RPM…and therefore out of sync with one another.  Sounds like BS, but I’m not that up on HDD technology)

I do not have problems with the drives in standalone…sequential/sustained writes occur at about 70 MB/s.  For now this means simply not using these drives in RAID.  One wonders if this is a firmware issue or yet another attempt to force everyone to pay more for “RAID approved” drives.  C’mon…if I’m buying a 1TB+ drive, what are the odds that I woudln’t be interested in securing my data with a mirror or going for broke with a massive single volume?  I understand that performance might not be AS GOOD as with black or enterprise, but I think intentially cripling the hardware via the firmware is just stupid in the long run.  Not to mention, as the first “Advanced Format” drives, you’d think they would want them to be as robust as possible to help with adoption.  If things keep up, NewEgg will have to throw one of these in free with every order of $100 or more just to get them out of their warehouse.

I hope this is just a firmware problem and not a marketing decision.

I originally poked around the slow transfer rate problem in the Windows forums, since my drives tested and formatted OK.  Now I’ll have to go back and check and see if the folks blaming Microsoft were running WD drives.

2nd Edit:  Interestingly enough, a striped array built in Windows disk management produced good results…110MB/s sustained writes and 70MB/s internal copies.  A windows mirror array was still epic fail though.  I like the portability of Intel ICH built RAIDs more…so the drives are still going back within a week if WD doesn’t respond to support request.  I’m willing to argue the levels of RAID peformance to a point, but as of now these drives seem like they have been crippled specifically to fail in RAID.


#13

After trying several different configurations, the best I got was a Windows striped array.  However, the results are less than expected.

It took close to 4 hours and 22 minutes to copy 613,460,801,006 bytes…so only 38.7MB/S onto the 3TB striped array.  I get better speed copying directly onto my WD10EADS.  Windows still did its usual inaccurate estimate of completion, but it seemed to jump around more than usual, sometimes going as hight as 12 hours estimation.

I’m going to try a full copy to a single drive to see if anything improves, but I have my doubts.  Regardless, if they can’t perform in a simple stripe or mirror, they are pretty much useless.

Booo


#14

i have same problem with my new wd green 640 gb    after installing windows7 the system running like p1  

i dont know what to do any suggestion for me … for the time being iam going to install xp or vista … just to see whether it solve my prob…


#15

You guys don’t check the WD FAQs do you?  It pays to research before you buy, especially since WD makes RAID specific drives that cost more than desktop drives.  Do you think they’ll give away RAID drives for free?

FAQ Answer ID 1397:

Western Digital manufactures desktop edition hard drives and RAID Edition hard drives. Each type of hard drive is designed to work specifically as a stand-alone drive, or in a multi-drive RAID environment.

If you install and use a desktop edition hard drive connected to a RAID controller, the drive may not work correctly. This is caused by the normal error recovery procedure that a desktop edition hard drive uses.

Note: There are a few cases where the manufacturer of the RAID controller have designed their drives to work with specific model Desktop drives. If this is the case you would need to contact the manufacturer of that enclosure for any support on that drive while it is used in a RAID environment.

When an error is found on a desktop edition hard drive, the drive will enter into a deep recovery cycle to attempt to repair the error, recover the data from the problematic area, and then reallocate a dedicated area to replace the problematic area. This process can take up to 2 minutes depending on the severity of the issue. Most RAID controllers allow a very short amount of time for a hard drive to recover from an error. If a hard drive takes too long to complete this process, the drive will be dropped from the RAID array. Most RAID controllers allow from 7 to 15 seconds for error recovery before dropping a hard drive from an array. Western Digital does not recommend installing desktop edition hard drives in an enterprise environment (on a RAID controller).

Western Digital RAID edition hard drives have a feature called TLER (Time Limited Error Recovery) which stops the hard drive from entering into a deep recovery cycle. The hard drive will only spend 7 seconds to attempt to recover. This means that the hard drive will not be dropped from a RAID array. While TLER is designed for RAID environments, a drive with TLER enabled will work with no performance decrease when used in non-RAID environments.

Earlier WD drives used to respond to a utility called WDTLER in which you could turn on TLER in desktop drives so they wouldn’t drop from a RAID array.  I successfully used it on two 640GB Caviar Black SATA drives to keep them dropping from a RAID 1 Mirror.  Worked like a charm.  Since then, WD has disabled this capability in the desktop drives so WDTLER won’t work on them anymore.  You’ll have to buy their more expensive RAID Enterprise (RE) drives, or go with a different brand.  Hope that helps.

Friar


#16

Friar, RAID isn’t a “feature” of a drive firmware. Charging excessive premiums for otherwise identical drives to “allow” RAID is a practice that needs to be stopped. If the only way Western Digital will learn this lesson is massive RMA of otherwise “functional” drives, then that is what must be done. For the record, my drive gave poor results stand alone as well. These drives were released before acceptable QA was in place, and with crippled firmware. The savings from TLER is negligible compared to forcing everyone to pay an extra 30%-50% for a few lines of code in the firmware. Thank you for underestimating our intelligence, and for cutting and pasting from the site’s KB into its BB. Believe me, everything was tried and researched to make the drives work first, as RMA is a PITA. The problem is WD attempting to create a new market which forces any reasonable person to cough up the extra money to get back the functionality which should have been there in the first place. Its a crime being committed against the digital community, and we must protest in whatever way we can. lolz, FTW!


#17

The ATA standard provides a command for Error Recovery Control.

See the following thread:
http://hdat2.getphpbb.com/hdat2-common-f3/wd-tler-samsung-cctl-seagate-erc-t186.html

HDAT2 should allow you to set the ERC timeout values. However, unlike WDTLER, they may not survive a power cycle.

http://www.hdat2.com/


#18

I had the same problem about 6 months ago with the 1TB Caviar Green drives. I originally bought two, one for me and one for a friend of mine. I tested them both under Linux and Windows, and on different PCs, and the behaviour was the same: every file transfer would start fine, but when it got to ~900MB, it would start dropping from ~70MB/s to a whooping ~8MB/s gradually, and keep dropping and dropping. Completely outraged, I asked my provider to change the disks, which he did. The new disks (same disks) behaved exactly the same. I remember they had a cache of 32MB, but still it’s no excuse for the ugly drop in performance. It is no excuse either that the drives are “power friendly” and spin at 5400RPM, since there have been benchs of these disks which score higher than some Seagate’s 7200RPM disks. I finally changed the two TB disks for 4 500GB disks, which were Caviar Blue and worked exactly as expected. Up to the day i’m reluctant to try again those Green drives, yet almost no other provider sells other quality disks like Seagate (the only alternatives are Hitachi or Samsung, which I dread most). If this behaviour is indeed because of WD going crazy and trying to “install” an “excellence” line and a “low end” line of products, then it is a real shame. Seriously, this was the last good HDD manufacturer I knew. Sad to see you go. PS: during the time I had the TB disks, no satisfying response was received from WD. I agree with was has been posted above: the QA process for this type of disks has been completely skipped.


#19

I have one of the WD15EARS drives. It’s a total lemon. I wish I never bought it, I hope it dies so I can replace it, but an RMA is just going to replace it with another one.

I have it in a mirror with a Samsung Silencer which is truly excellent. The performance of my backup server is *so* much better when the WD green drive is removed.

I too disagree with the marketing notion of being force to buy an expensive drive for a firmware option. My machine doesn’t need to do lots of work, low power consumption is a primary concern. Data reliability by having a mirror is also a priority. Seems Western Digital’s marketing don’t want to sell into this market…

They want customers who want either a cheap low power single drive, or for more money a RAID capable drive. Not both. I tell you the Samsung Silencer does both. That’s the last WD drive I buy for a long time.