Caviar Black vanishing

I have a really strange issue and could appreciate any insight on this. Whenever I used my secondary hard drive to move stuff it will instantly just vanish (not just from My Computer, but from disk mgmt) a few seconds into the transfer. It seems to happen mostly when moving large amounts of stuff. It wasnt always doing this, just started a few days ago but I’ve only had the drive and the motherboard a week or so. I used the tool on Western Digitals site and it said the drive was fine. Any ideas on what I should do next? 

I have tried other drives, they work fine. Just this one. 


Western Digital Caviar Black WD1001FALS 1TB 7200 

here some suggestion you should try :

  • do you plug the drive to SATA3 port ? if yes, try plug it to Intel SATA2 port

  • try updating your bios, you should also update Chipset and SATA controller driver 

  • replace SATA cable

hope help 

Hi sdc88. I have a 1TB Caviar Black (WD1002FAEX-00Z3A0) that had a similar problem. WD Q&A suggested turning off write caching which did not fix the issue. The drive would disappear from the computer and Computer Management as well and not even a warm boot or reset would bring it back until I turned off the computer for a few minutes and all was back working fine again. As soon as I wrote anything large to the drive (anything over 500mb approx) I would get a Windows Write Delay Failure. Now my issue was writing to the drive. It would get the file written approx 3/4 done and the drive would lock up then just disappear. I have researched my problem for months using ideas from WD Q&A section and my own ideas. I have a WD 2TB external drive with no issues and 2 other different manufacturers internal drives as well with no issues plus my system drive with Windows on it is also a small WD 200mb drive with no issues. I run XP and i’m not sure but I think from what Microsoft information I have found it could be an XP issue. I have tried jumpered pins 5+6 to slow the drive down from its 6GB/s to 3GB/s and that is fine for a slower reliable speed. I also had write caching on the drive enabled  too at that time.  On one of the WD Q&A pages it mentions a Microsoft link (;en-us;330174) pertaining to XP issues with write delay failure so I checked that out and have had success so far with no disappearing drive plus I am now running the drive back at full speed (no jumpers on the drive) and have write caching re-enabled to no adverse effects either. Time will tell. The section on the Microsoft link mentions a registry setting…Workaround: Increase the number of page table entries…this is what my problem turned out to be. It was set too high. If you have XP and are capable of editing the registry give it a try…check the link to Microsoft and it will tell you how to do it…the setting I used for their suggestion was to change the setting I had (which was far to quick) to 7FFF in that part of the registry. As I mentioned its clearly explained in that link I posted. I dont know how the setting was changed (from its default of 0 to some ridiculous high number) but i suspect some tweak program I had used at some stage or possibly a trojan caused it. I am convinced something changed those registry values to a very high value thus upsetting the memory allocation far too high and running me out of paged pool memory which in turn upset that very fast drive only. All my other internal drives are not as fast as this Caviar Black 1tb. When you say “move stuff” i’m assuming you mean reading from it so maybe this doesnt pertain to your problem but worth checking out the article and their suggestions anyway to see what your registry setting is set at presently. Like I said…my problem happens when WRITING info to the drive. Anyway have a look at the Microsoft article and see if it pertains to your problem. Mine is an Intel board btw.

Good luck.



Further to my previous post…If all else fails put a plastic jumper on pins 5+6 (refer to WD diagrams for your particular drive to the location) which halves the speed of the drive (in my case from 6GB/s to 3GB/s) and try it also with Write Caching To The Disk Enabled. I have had more success on that combination than any other. The writing is slower but it does get there and I have had no drive disappearances or lockups either. Its better to have it working slow and sure said the tortoise to the hare and get there, than not at all.
To enable Write Caching on the drive if unsure and you run XP…Left click on “My Computer”, right click the appropriate drive, Left click “Properties”, Left Click “Hardware” tab at the top, Choose the drive again in the list with a Left click, Left click “properties” again at the bottom of the properties box, Left click “Policies” tab and Enable the write disk caching (or disable it if problems as WD suggest). There might be a better way to do that but thats a tried and true method of disabling the caching. I have had no problems using that particular method as a slow and steady reliable way of writing to the Caviar Black 1TB drive. Click OK a couple times to close the boxes and reboot. Give it a try as it works for me on my Intel motherboard with the SATA Caviar Black drive…
Of course if using the WD Caviar Black WD1001FALS older drive that transfer rate is 3GB/s so you would be halving the drive with pins 5+6 jumpered to 1.5GB/s Mine is the newer WD1002FAEX 6GB/s Caviar Black but with the same write issues.
I have tried all the suggestions by the previous poster (Slyphnier) with no reward unfortunately. All good suggestions. I have the latest chipset and sata controller drivers for my Intel board from them too, plus 3 new cables to no avail.
Anyway this particular method worked for me as I have said when nothing else worked, so best of luck.