Caviar Black 1TB: Really bad (?) SMART status "Hardware ECC Recovered"

Hi folks,

I searched all over the internet for an answer before posting, but I’m giving up for now.

I bought a new Caviar Black 1TB yesterday to replace a possibly flaky Caviar SE16 640GB (the 6400AAKS). I made sure to take a snapshot of the Caviar Black’s SMART status on first bootup, using HDTune 2.55 as my SMART status reader. I quick formatted the drive (in hindsight maybe should’ve done a full format…), partitioned it to 160GB (for the OS) and the rest for data storage. I then proceeded to copy about 200GB worth of data to the 2nd partition. Finally I installed Windows Vista Business 64-bit on the 1st partition.

Today I took a look at the Caviar Black’s SMART status and everything looks fine (no read or write errors or bad sectors found) but the “Hardware ECC Recovered” field has changed greatly!

Here’s what the field said when the Caviar Black was unused {Current 100, Worst 253, Threshold 0, Data 0, Status OK}

Now it says {Current 1, Worst 1, Threshold 0, Data 32482784, Status OK}.

What does the ‘Hardware ECC Recovered’ field mean? It sounds like some measure of  data errors that were corrected by the harddrive’s ECC mechanism. From what I read online, the normalized SMART values are worse the smaller they are…in this case the Current and Worst values are 1 which is as low as it gets.

I tried a bunch of things like using new SATA cables, changing to different SATA ports but the field status for “Hardware ECC Recovered” data readout always hovers around that number. Current and Worst continues to stay at 1.

I also tried running the WD diagnostics but I keep getting cable test errors in Vista. I tried running the DOS version from the CDROM at boot but it complains that it can’t find the license file (although the file is clearly there)…

Performance seems to inline with reviews I’ve read. Using HDTune and HDTach to benchmark, the drive averages about 89MB/s, starting around 110MB/s and ending around 60MB/s as it moves towards the end of the drive. Seek times around 13ms, which is also okay.

Please let me know if I should be getting this drive exchanged; or if this is normal. Include technical explanations if possible…I would like to hear it.

Thanks.

EDIT:

Here are some screenshots.

Caviar Black 1TB new (date 12-14-2009)

Caviar Black 1TB one day old (12-15-2009)

WD support got back to me about this issue and told me to return the drive.

I will, but in the meantime I bought another Caviar Black 1TB to check…and guess what…the “Hardware ECC Recovered” status field is not shown in SMART!!!

Here’s the screenshot of the 2nd unit SMART readout:

What the hell…

Physically the two drives look different too. The first unit had a white sticker over the usual jumper settings diagram. It also had a different looking PCB and some odd sticker on the side…

I wonder if the first unit I received is some kind of test unit that got out. Poooor control.

Based on the model numbers it looks like your first drive was an OEM drive, and the second a retail drive. All the drives i’ve bought as retail drives have -00 in them, and the ones that came from OEM machines have -XXs… I guess this could be a coincidence, but the numbers have to mean SOMETHING, and i’ve seen a LOT of WD drives…

I have the same problem on both of my 1T harddrives bought less than 1 month ago.

waiting on a reply from WD now.

I’m the owner of several WD1001FALS drives, all have a -00XXXX suffix and were purchased in the last couple months at a Best Buy in Michigan.  So far, they have been great HDDs…

Last week, however, I bought another one and saw some very strange behavior while I was doing my standard initial “qualification” testing – in particular the Hardware_ECC_Recovered (SMART attribute 195) normalized value had dropped to 001 after several hours of r/w testing.   In brief, exactly the same symptoms reported in this thread.  I also found this Best Buy review which is describing the same issue…    As others have reported, the drive has a white sticker obscuring the jumper setting instructions on the drive label.

After realizing lots of people thought this might be an OEM drive I did some further searching that revealed it was apparently manufactured for Apple computer.  Do a Google search on “40U9B0” and you’ll see multiple hits on people discussing this drive as the OEM drive for 27" Apple iMacs made in late 2009.

On Thursday I reported this problem to WDC Teir 2 technical support.  They seemed to take the report seriiously and requested photographs of the drive and its retail packaging.  I provided these along with Linux ‘smartcltl’ output.

It would really surprise me if WDC had intentionally dumped OEM drives with random custom firmware into their retail channels.  Hopefully they’ll get to the bottom of this issue…

For reference, here’s an image of the odd-ball -40U9B0 “retail” drive:

image of WD1001FALS-40U9B0

i am having similar issues.  AVG seek times in hd tune are 17ms where my other 1tb caviar black is 12ms.  Bought this new one from BestBuy in jacksonville FL im about to take it back though.  I am seeing same things others are seeing.  white sticker over back different firmware and obscure model number that relates to an IMAC.  We will se how friendly bestbuy is.

Sorry to hear these drives are still lurking out there…

I had no trouble exchanging the drive at Best Buy during the refund period.   Didn’t make a big deal about it, just told them about the SMART issues and mentioned the sticker (which the guy at the desk admitted was weird).  I opened the replacement drive box right at the customer service desk and verified it was a -00XXXX drive and didn’t have the white sticker.

Don’t know if it is significant but the replacement drive packaging had three OS emblems on the top flap: OSX, Vista, and Window 7.   The “OEM” drive box only had OSX and Vista.  Interestingly the manufacture date for the replacement drive was earlier (Oct 2009) than the “OEM” one, even though the packaging appeared to be newer.   Could be totally random, but figured I’d mention it just in case it’s a way to avoid buying any remaining -40U9B0 drives out there on shelves.

Does anyone still have one of these drives that they are looking to get rid of?  I have the same exact drive, sticker and the same 40U9B0 firmware.  My controller board burned out and I cannot retrieve the data off of my drive.  I heard swapping the controller board may work as long as it is the same firmware revision.  The date on my drive is October 15 2009.  That would probably even be best, but I’ll settle for the same firmware.  I have three other WD1001FALS but none have the same firmware and their boards do not work on my drive.  Any takers?

Can you upload a detailed photo to a file sharing service?

A straight board swap will most probably not work. You will probably need to transfer the serial EEPROM chip from patient to donor. This chip stores unique, drive specific calibration data. Newer models store these data within the main MCU chip, in which case you will need to find a board supplier who will transfer the data from your old board to your donor.

If you are lucky, the damage to your board may have been contained by TVS diodes and fuses, in which case there is a very easy DIY fix.

I will try to upload some pictures tonight.  Basically you want to see both sids of the board? 

The component side will be sufficient, unless there are components on both sides.

Here is a link to the photos I put on Snapfish.  Hope it is helpful.  I tried forever to get clear photos, but this is the best I could get.

http://www5.snapfish.com/snapfish/thumbnailshare/AlbumID=1469744027/a=2861790027_2861790027/otsc=SHR/otsi=SALBlink/COBRAND_NAME=snapfish/

The SMOOTH motor controller has obviously failed. :frowning:

The EEPROM chip is the 8-pin device at U12, below the Marvell MCU, near the SATA data connector. This will need to be transplanted to the donor PCB. It contains “adaptive” data.

Also, I would measure the resistances between the motor terminals to confirm that none of the 3 phases are shorted or open.

If you are not experienced in soldering, then ask your local TV/AV repair shop.

See this thread:
http://www.deadharddrive.com/forums/viewtopic.php?p=9531#9531

The OP writes that s/he "took the board to an electronics repair store and for $20 the ROM chip was swapped. "

Thanks,

I’ll give it a shot.  I actually have another drive that was also fried when this one fried.  I have a donor board for that drive and tried to have the U12 Rom replaced.  I spoke to about 4 different “Electronic Repair Stores” and they all said they don’t do it.  I finally took it to a compuetr store and he said he’d do it, but he called me later saying he couldn’t do it.  When I went to pick up the boards, he showed me that he tried to desolder the chip from the donor board and he damaged the chip.  Thank god he didn’t touch the original U12 chip with my info.  When I got home I tested the board he had worked on and he burnt it out.  I got another board now but was very nervous to have to worked on seeing what the first guy did to it.  The video looks so easy.  I’ll give that a try.

Chip removed very easily with the heat gun.  I made the swaps (at my brother’s house) and then connected the drive to my computer (at my house) and the drive no longer spins.  Originally when the board burnt out it wouldn’t spin.  With the replacement board connected (with the U12 Rom it came with, not the one from my bad drive) the drive would spin, but wouldn’t be recognized in the BIOS.  Now I swapped the U12 Rom and the drive no longer spins.  Do you think I burnt out this board?  I noticed when replacing the U12 Rom, it is not in the exact spot the old one was.  All contacts are touching that I can see, but it is definitetly off to one side.  Should I try to center the U12 Rom?

It doesn’t look good. :frowning:

Can we see a photo of your work?

Hadn’t bought a CB 1TB in a few months, but went down to Best Buy today to get one.  Due to my experience with this issue previously I’m now in the habit of popping the box open in the car before leaving the parking lot to verify the drive inside is the correct model.   Imagine my surprise when I found this:

(Click here for full size image.  Sorry for the reflections; it is hard to take a photo through a semi-mirrored surface with daylight all around.)

Still appears to be an Apple OEM drive (40xxxx), but following four digits slightly different than previously.  Couldn’t find any significant Google hits for “WD1001FALS-40K1B1” or even just “40K1B1”, assuming I’m reading that right…

Best Buy allowed me to exchange the drive and check another one with as different a serial number as I could find.  That one was fine.   I really wonder why this is still happening.     The 11 Apr 2010 manufacture date is almost six months after the previous batch that appeared to have slipped out.  Since I never even fully opened the packaging I can’t be sure it would have exhibited the same issues, but that sticker covering the jumper setting is a big enough red flag for to me to stay well clear of this variant of the drive.