Casting Music with My Cloud Mobile App

I can access my MyCloud EX2Ultra NAS files with the MyCloud mobile app. But when I want to play music, I’m not finding an option to cast my music to a network speaker. It just plays on my my tinny phone. Am I missing something?

Play music on phone via WD app and use bluetooth of phone to stream music to the BT speaker. There are other ways, too, so do some research to find other ways.

Hey, mike27oct, thank you for the response! Actually this is exactly what I was trying to do. I am connected to my Riva speaker via WiFi or Bluetooth through my phone. I can open the Riva speaker app on my phone and play music from my NAS just fine. But when I try to use the MyCloud app on my phone to play music from my NAS, it will only play on the phone itself. I cannot find an option to cast it to the Riva speaker.

I’m sure it’s me missing something simple!

There is no option in MC app for casting,you must use phone’s BT. I believe Android app has ability to send via (chrome)cast to a google device. Open Settings/Help in MC app for more assistance.

I am already connected to my device/speaker via Bluetooth on my phone. I think you’re correct that my Android app can send via Chromecast, but I don’t have a Google device. The Settings/Help in MC had zilch for help. What I would like to be able to do is access my music on my MyCloudEX2Ultra while I am camping in my RV with WiFi and then play it on my speaker system in the RV.

Not looking like this is going to be an option though. Oh, well… thanks for the help!

One more try for you:

Can you play ANY music from your phone via BT to your speaker? If so, then you also should be able to play from NAS when at home on your home network from MC app/phone to same speaker.

When not on home network ( eg on RV wi-fi) you are making a REMOTE CONNECTION, NOT A LOCAL ONE. Your NAS must have CLOUD ACCESS set up and turned on so when you go through the RV wi-fi it will connect to home router and can access the NAS. Refer to the complete NAS user manual for this.

I can do the following on my iPhone (and you can do the same) with cloud access on:

  • I can connect MC app to any wireless wi-fi (including my cell data Plan) to play music (or movies) from NAS and on to a BT speaker.
    I often connect via data plan-only before leaving home to be assured remote access is working properly, but if not, rebooting router can usually fix things. GOOD LUCK!

OK… now I think we’re on to something. I spent all day Saturday getting a new Onkyo receiver set up to stream from my NAS to an outdoor speaker, play music from the TV to some wired outdoor speakers and even to cast music from my desktop computer to the wireless outdoor speaker and the Onkyo. I am a 70+ year old grandma, but I can build you a killer gaming computer… this stuff, however, makes my brain hurt!

I believe, I have enough to make this work now. You’ve been a great help and I think I need a beer now. Thank you!

OK, so you are a grandma, well I am a 70+ YO grandpa who does not play computer games so no need to build me one, but be sure you have the full manual on your NAS or download it from WD Support.

Just remember the adage, RTFM!

I want to hear back that you got this issue solved!!

LOL! I will definitely do that. Got grandkids from Colorado coming in this week, so it’ll be after they leave before I get back to it. Already have that full manual and have been poring over it since the marathon on Saturday.

The Cloud Access for turning it on is in dashboard Settings /General.

I found a very easy-to-understand video tutorial from youtube. I think it’s not hard to do. I can do it successfully on iPhone Xs and Sony Xperia XZ

Thanks, benjaminky. I will definitely check it out! I finally got it to work from the app, but now I can’t get the MyCloudEX2 Ultra to be available outside my network! Will probably end up posting about that too.

Rebooting NAS may help last issue. ALWAYS reboot router first THEN afterwards reboot NAS to ensure NAS has the correct port-forwarding IP address for cloud access function.

Right now, we’re working on the Remote Access issue. I had to set up a manual port forward on my router, but using canyouseeme, it is still getting rejected on port 32400. I have a request in to my ISP to see if they are blocking the port. I haven’t tried rebooting the NAS, so while I’m waiting to hear from my ISP, will try that too.

I doubt manual port forwarding is a solution. Read some of my earlier comment to you.

It obviously isn’t going to be a solution, but that’s the direction the mods in that forum were sending me. Will go over your previous comments after I take the Bloodhound in town for a bath.