Capacity changed from 1.81TB to 931GB


#1

I bought a 2TB Passport Essential SE a couple of month ago, it works fine until last week.

My friend plugged it to his macbook air and find its capacity became 931GB! when I use my own computer to check it, the situation stay the same.   

I backed up all my data to another portable storage, and formatted my 2TB HDD, nothing changed.

Fortunately, the file seems not damaged, and the hard disk looks no problem except the 1TB capacity lost.

Anyone can help me? Thanks in advance!! QQ20120808143515.jpg


#2

check the unit on the disk management to see if the unit has a unallocated capacity. It might happen


#3

That’s very strange. In fact I recently saw a very similar problem at Seagate’s forums, also with an external 2TB drive on a Mac. As yet there is no resolution in that particular thread.

Could we see HD Tune’s Info tab?


#4

20120808143515.jpg

i found someone says its HPA problem.

but i cannot install the solution software " HDD Capacity Restore Tool" bcz my pc is X64    XP

PS: cant login those days


#5

thank you for your help,:smiley:

but

no, it shows all space allocated


#6

The first image (QQ20120808143515.jpg) in your first post still has not been approved (nor has your latest one, 20120808143515.jpg). Is there something wrong with it, or has the moderator missed it, or is it a problem at my end?

As for your 1TB issue, I also thought it may have been a HPA problem, but I haven’t yet seen anyone say that they were able to create a HPA via USB. What I find strange, though, is that you were able to recover your data. Did your Passport have more than one partition? Were you able to recover all your data, or only a portion of it? AIUI, if the partition were truncated, then the file system would have been detected as RAW. Did you run CHKDSK on your drive?

The fact that the capacity is 1TB (= 931GiB) rather than 1TiB (= 1024GiB) tends to rule out driver issues. 1TiB would be the limit one would expect for a 31-bit LBA. Instead it does look like a HPA problem. That’s why I’m waiting for HD Tune’s Info tab.

FWIW, I have seen similar HPA problems when 1TB+ SATA drives are attached to certain Gigabyte motherboards with a buggy Xpress Recovery BIOS, but yours doesn’t seem to fit this category.

BTW, I’ve also been having login problems (aside from the unintelligible Captcha annoyance which has since been resolved - thanks WD).


#7

fzabkar thank you so much!

the first image cannot shows in my browser too, but I can see the latest one “20120808143515.jpg”.

  1. I only using one partition.

  2. I’ve recovered all my data. Some files in the passport I just deleted because I have copy in another drive.

I am sure that approximatly 500GB’s media files haven’t been damaged.

3.I haven’t run thoroughly CHKDSK, but every diskcheck software shows the drive is only 931GB.as well as Acronis Disk Director Suite. no RAW file system have been detected. Should I use CHKDSK :/r to do so?

BTW, I recently reinstalled my OS, but I think it is not a problem, because I’ve got another 2TB Hard drive(not passport) having no such problem. (so my motherboard is good too?)

cheers for that Captcha !

20120808143515.jpg


#8

There is no point in running CHKDSK now that you have repartitioned and reformatted your drive. Had you run it before, I suspect it would have complained of read errors beyond the 1TB limit. Moreover, since the original MBR has been rewritten, we can no longer examine the old partition table.

As for HD Tune’s Info tab, it doesn’t show the information I was looking for. In particular I was looking for the model number of the HDD, eg WD20NPVT or WD20NMVW (perhaps the drive doesn’t report this?). Do other utilities, eg HD Sentinel, show this information?

Could we see HD Tune’s read benchmark graph? This will tell us if the drive has been short-stroked, which will in turn support the HPA hypothesis. You will need to achieve USB 3.0 transfer speeds for this benchmark to be useful, otherwise we will only see a flat line.

The ATA standard provides a READ NATIVE MAX ADDRESS command that can detect the drive’s full native capacity. However, I don’t know which utilities, if any, are able to retrieve this information from the drive via USB. Perhaps hdparm can do this?

BTW, I still can’t see 20120808143515.jpg.


#9

Here is what I mean:

http://www.legitreviews.com/images/reviews/1951/hdtune-read.jpg
http://l.yimg.com/fr/xp/tech/paragraph/computerdiy/2012/07/13/news_38388_3.jpg
http://www.52hardware.com/upimg/allimg/110216/55_110216102010_1.PNG
http://2e.zol-img.com.cn/product/54_500x2000/772/ce9tLwd7FiMrU.jpg

Notice that the transfer rate at the 0% mark is about twice the rate at the 100% mark. These represent the rates at the outermost and innermost zones, respectively.

Now if your drive has a HPA, then the innermost transfer rate will be at the 50% mark, ie at the 1000GB point. The ratio of transfer rates would then be about 1.25:1 rather than 2:1.

Edit: Here is a HD Tune read benchmark graph for a My Passport 0740 (1000GB):
http://www.ocmodshop.com/wp-content/uploads/2011/08/HD-Tune-Pro-WD-MyPassport-1tb.jpg

Notice that its average transfer rate is 64.4 MB/s. Your HD Tune Info tab is reporting an average speed of 63MB/s. Assuming there is nothing strange about your HDD’s performance curve, then this would suggest that you do indeed have a fully stroked 1TB drive, not a cut-down 2TB.

What is the part number on the enclosure?


#10

hello. i have a hard drive and with similar issues and if the MBR has been corrupt, can you still still see the storage space in disk management?

sould it say 1.8TB in disk management or should it say 930GB?

also i tried to leave a comment on this link but it was closed. I hope some can im me or instruct me how to leave a new post. here is the link with the similar issues.

thanks a bunch

http://community.wdc.com/t5/Other-Internal-Drives/WD3200BEVT-failure/m-p/283712#M1780


#11

@Daniel, I saw your PM, and I’m still thinking about your problem. Unfortunately, I don’t believe that I know enough to be able to help you.

To answer your question, a corrupt MBR is a logical fault, not a physical one. This means that the drive will still correctly report its capacity to Disk Management. However, if the partition table is corrupt, then Disk Management may not recognise the partitions, ie the disc space might be seen as “unallocated” or “uninitialised”, or the file system may be seen as RAW.

If the drive’s capacity has been reduced by means of a HPA (Host Protected Area), then the drive will report this reduced capacity to Disk Management. In this case Disk Management will not be aware of the drive’s original native factory capacity. Windows will still see the MBR, but it may complain that the partition sizes exceed the capacity of the drive.


#12

what a pity, I don’t have usb3.0

I tried to contact one of my friends in the past few days, but he’s HD tune pro don’t have the Benchmark start buttom…

here is HD tune pro info tab, i uploaded it.

http://www.freeimagehosting.net/lm7ro

HD Sentinel 

http://www.freeimagehosting.net/izva4

         

Oh, i forget to tell you that i updated its firmware,  i downloaded from WD offical web, and I’m sure its for Essential SE.


#13

 hdparm is for Linux?

one of my friend told me that i probably bought a fake drive, because i can’t find  a 2TB drive in this model now.

But I remember I put more than 1.4TB data in this drive at once.

the model info will change if i installed the wrong firmware?  


#14

As you’ve no doubt noticed, HD Sentinel is detecting the HDD behind the USB-SATA bridge IC as a WD10TMVW, which is a 1TB model. A 2TB drive would have a model number similar to WD20TMVW.

Inside the enclosure is a USB-SATA bridge IC with its own bridge firmware. Behind the bridge is the WD10TMVW HDD, also with its own HDD firmware. When you apply WD’s Passport Essential SE firmware update, you are actually updating the bridge firmware, not the HDD firmware. The bridge firmware reports the model number of the USB mass storage device, namely WD Passport 0730, while the HDD firmware identifies the HDD model, namely WD10TMVW. Therefore the HDD’s model number cannot be affected by the update.

IMO, your external HDD really is a 1TB model. You may be able to confirm this by examining the part number on the enclosure.

BTW, here is a thread where “Gaucho” succeeds in replacing the bridge firmware in a HP SimpleSave drive with the firmware from a WD external product:

http://forum.hddguru.com/disk-with-sata-usb-adapter-remove-virtual-rom-t18492.html

He does this by way of an invasive hardware hack. As in your case, his HDD’s model number remains unaffected.

As for your hdparm question, there is a Windows version of this tool. You will first need to install Cygwin, though.

http://www.cygwin.com/ml/cygwin-announce/2007-03/msg00000.html
http://en.wikipedia.org/wiki/Hdparm