Can't view the User Interface

I’m using WD Smartware on windows xp and firefox.  I can’t view the UI anymore. Shouldn’t I see it when I put http://mybooklive/ in the web browser?  I even click on Open and Dashboard in WD Smartware and get a browser error.  I mapped the drive and I can view the files that way.  Please help.

You can see the UI for Smartware or you can’t access the dashboard? 

If you can’t see Smartware UI, try running it from programs or from the icon on the task manager. 

If the problem is with the dashboard, just open a browser and type the name of the drive and I’ll give you access to the dashboard. Any browser should work, if seen some problems when using Chrome before.

Nothing opens when I click on the WDDMStatus program.  I tried opening with task manager but nothing happened either.  Should I uninstall WD Smart Ware and install it again?

You can also run the software by going to start> programs > WDSmartware. 

Also when you click on the icon for Smartware on the manager (bottom right hand corner on your pc) it will give you options for Safely remove and Smartware, you’ll need to click on the Smartware option and then the software will launch.

Last but not least, you can go to Computer and run the software from the VCD (if you have and older Passport) or from the drive it self (there’s an exe file for Smartware there)

Thanks I just reinstalled it and smartware works.  But dashboard doesn’t work still, an error shows in firefox.  This is the address it shows http://mybooklive/

What’s the error?

The Firefox browser says “Unable to connect     Firefox can’t establish a connection to the server at localhost.”

But I guess it doesn’t matter since I can use Smartware and access the files in the mapped drive.

Is Firefox configured to use a proxy at localhost?

I don’t know.  Under firefox network settings this box is checked:  “use system proxy settings”

Well, your error is  “Unable to connect     Firefox can’t establish a connection to the server at localhost.”

localhost is your computer.  And this is odd because why is it trying to connect to localhost if you’re trying to connect to  your MBL?

One answer is that it’s trying to connect to a proxy at localhost and can’t.  Trying setting Firefox to connect directly to the internet so that it won’t use any proxy.

I am having the same issue. Last night I could get in fine. TOday… I can’t. I can access the dive ok. and I c an access the files ok.

The WD Smartware sees the drive but can’t get to the interface.

Please… don’t pin it on the computer itself always… THere is obvioiusly issues with this drive. This is my second one and its giving me a hard time too.

i think the newest firmware resolved an issue where you’d lose the dashboard if your router assigned a new dhcp address.

Are you reserving an ip for the drive?  What happens if you just type that ip into the browser?

Did that… it cannot be displayed… i still can access fine everything… even ssh.

If you can access sssh, try following the directions in the firmware announcement thread and update the firmware to the latest version (unless you have already done that).

i cant access the gui.

I can go to http://mynas:9000 and twonky loads, i can access all shares and wd2go loads, i just can go to http://mynas and get the UI. The browser redirects to http://mynas/UI but then just loads blank.

This only happened immediately after latest firmware update. No ssh enabled, no ftp enabled. Over 2 TB data, and erase really not an option.


For those of you having issues accessing the MBL through the friendly name, this is likely a DNS cache issue. We looked at this all weekend and did not see any issues on our side. One thing you can try to do is access it like :

http://mybooklive.local (for a PC)


http://mybooklive.local. (for a Mac)

Let me know if this helps.

i tried both of the .local links you provided on my mac and pc, and still same result. 

other ideas?

Can the unit be accessed by IP address?

try changing your DNS?  put in or to use google’s.  Or, if you’re using that, some other one. that solved all my dashboard issues months ago.

i can access the shared files locally, i can use twonky services, i cannot load http:/mynas or http://192.x.x.x for nas.

when URL typed the page redirects to http://mynas/UI when trying to load any of the pages in /UI i get a

CakePHP: the rapid development php framework

Not Found

Error:  The requested address  ‘/something.php’  was not found on this server.

if i go to http://mynas:9000 i can access all twonky stuff.

Static dns on LAN Link does not change anything.

Anyways not sure whats going on, but hope that helps