Cant use Favorites Menu

Hello all.  I have newer model of the WDTV Live. Recently I started having a problem where I can not use my favorites menu.  I can pull up the menu, but all my favorites are gone and I am unable to add any favorites.  I thought that maybe I need to reset my WDTV so I tried that, but a reset/restore no longer works.  A restore does absolutely nothing. When the WDTV restarts all my settings and services are the same.  I even tried the reset button on the bottom of the unit and it does the same thing.  Can anyone give a recommendation as to how I might fix this problem?

Thank you.

if you mean you have a WDTV Live Streaming (SMP)

Turn your “Media Library” ON     (If it’s set to OFF this Disables Favourites, Star Ratings etc)

Setup > System > Media Library > On

I dont know if the model I have is called a WDTV Live Streaming, it only says WDTV Live on there.  This is the one I have,

I did try what was said though, and I did have Media Library set to on.  I turned it off, cleared the library and then turned it back on to see if that would work and it didnt. 

I also find it really weird that no matter what I do, I can not restore the unit to the factory defaults.  It just keeps all the settings no matter what.

Are there any other recommendations for a solution?

It looks like you’re not the only one with this issue. I’d already posted in another thread before I saw this one:

The original poster had a combined problem relating to his Media Library, but both of us have the same problem with “My Favorites”. Perhaps we could keep this in one thread or update each other if anyone makes any progress with this problem?

I would like that.  The favorites is used a lot in my house and although we can still access everything without that menu, its still nice to have for convenience.

Are you able to restore to defaults or does yours do what mine does, reset and keeps all settings?

I found that whenever I reset to factory default settings nothing seemed to happen. However, I discovered that something more was going on than I had first realised. I changed my own desktop picture back to the default by selecting the “Mochi” theme, removed all the network shares in My Media Library, and disabled the Media Library. Then I did a factory reset and… my desktop picture was back, the network shares had been reinstated, and the Media Library was turned on again. In other words, the box had somehow saved my settings as the factory settings. It is clear that these settings and/or internal software were corrupt: causing problems like not being able to use/modify My Favourites, so I was unable to resolve the problem. I contacted support by telephone and they were very helpful. After we had been through all I had done they told me that my box needed to be replaced. As it was still under warranty and I bought it from Amazon I was able to arrange a replacement; I didn’t want a refund because I still believe this is a cool piece of kit. As I have come to expect, Amazon were very efficient in the replacement process and I had a new box the next day. I put my old box in the packaging they sent, printed off a returns label, and took it to a local “Collect+” centre.

WD support said that if I was unable to get a replacement from Amazon they could arrange for a replacement. However, it would be a refurbished box. Personally I would have had no problem with that, but I was fortunate.

Obviously I have no idea what caused the problem, but I’m up and running again and very happy.

Thanks for the reply. I wish I would have got the reply a little earlier as I did the firmware update that I was prompted to do on my WDTV and now I appear to have a bricked WDTV Live.  The unit starts but just goes to the WDTV Logo splash screen and will stay there forever. Ive done hard resets and power unplugs and still nothing. I call WD at around 4:50pm PST time and my call was answered at 4:59pm.  I was promptly hung up on.  I called right back just to get a recording that they were now closed. 

I cant tell you how frustrating that was.   We used out WDTV A LOT. Now I have a whole weekend of no netflix, hulu, or other movie service.  Ive always told people that WDTV devices were great, but I feel that Im going to have to start reversing my thoughts of them.   Ive just had so much problems with this unit over the last couple of months.

What a nightmare! I wouldn’t give up on the WD device just yet. From what you said: “Ive just had so much problems with this unit over the last couple of months”, it sounds like you had a unit on the brink of failure for some time. The internet has changed the world for the better in that we can share and talk openly about problems with things we buy - without the internet we’d never know if our problem was in isolation or if other people have experienced the same issue. However, the downside is that it can often be misrepresentative. People aren’t going to flood the forums with how great and reliable their purchases are rather they use the forums to discuss problems, so it creates an inbalance. If these forums were filled with complaints similar to our issue then I would begin to suspect the problem is more serious, but we are very few among a massive number of units sold.

I hope your confidence is restored when you call support next week, but let us know how it goes. It’s always useful to let others know how good/bad support can be.

In the meantime it sounds like you’re going to have revert back to entertaining yourself the way we did before we had all these internet services. Maybe some good old fashioned family time? Can any of us remember how we that works? :wink:

Ahhhh, good old fashion family time. Let me assure you, that’s not lacking here, but with temperatures having been very high outside it makes it a little uncomfortable to be out and about. That’s why our wdtv has been getting so much use. It’s much nicer to be inside with the a/c on and just watching some tv.

As for giving up on the wdtv products, I guess I should wait to see what happens. I was just pretty upset yesterday cause I hate dealing with stuff like this.

I had the same issue and I figured it out.  I had to have a USB flash drive or hard drive connected to the WD Live player and then after that I was able to make changes to the favourites menu.

Well, I got a replacement and the problem is fixed with the replacement.  WD made the replacement process fairly simple and has restored my faith in them.