Can't use down or back buttons on remote

I used to like my media hub, but today I hate it. I can’t use the down or the back button so I can’t get to the videos I want to play. I’ve tried putting new batteries in the remote and shutting the thing off and turning it back on. Has anyone else every have this happen?

The remotes aren’t the highest quality; they do ocassionally fail.  But there are some things you can check before calling WD for a new remote.

Try looking at the remote’s IR emiter through a camera phone or digital camera to see if you can see any illumination when you use those buttons (most camera CCD’s can detect infrared and displays it as white light)

Also check your remote to see if there are any stuck buttons being held down.

My newest Hub remote did that a few weeks ago after being crammed into a sofa cushion for who-knows-how-long…

Thanks. After shutting down for a while, I turned it back on. Now only the key that doesn’t seem to work is the down arrow. Nothing appears to be stuck. Nothing happened to the unit or the remote. It worked the last time I used it and today it didn’t work. (Everything worked except for 2 buttons.) I did find that they have other views and I was able to select one of them and I could use the up arrow to scroll around to the bottom and then arrow up to the video I wanted. That didn’t work in some of the views. In some of the views, instead of going to the bottom, it went up to the function keys and wouldn’t loop around to the bottom. At least nothing I tried worked.

I saw some people say they were using a keyboard instead of the remote. I bought one of those microsoft arc keyboards. I will be trying it shortly.