Cant upload photos from ipad

I’m trying to archive some photos from my wife’s ipad onto my mybooklive. Installed mycloud and photo. Both apps can see the mycloud and access stuff on it, but when I try to upload all the camera roll it does nothing - the screen says it is uploading, but no files are moving and eventually (hours later) I see that it has failed - but no reason given.

I’ve no idea where to look for help or more info - any help welcome.

There are a lot of photos (about 500)

I have increased the cache size

I have never had it working, but just upgraded to the latest ipad software.


Hi angusweir, are you trying to upload the files while connected to your home network or using your phone data plan? Have you also tried to copy a single picture to see if it works? 

thanks for response, it was whilst connected on my home network.

On one occassion I tried to send the whole camera roll (select all), and one photo got transferred and then it just stopped, so I increased the cache size and nothing happened at all on future attempts.

I haven’t tried one photo at a time (there are loads of photos so if that is the only option it is of no use to me - but obviously happy to try for diagnostic purposes).