Can't update firmware

I have an older My Book Live drive that requires a firmware update to work with the latest build of Windows 10. Problem is, while Win 10 can see the drive on the network, it won’t connect to it in order to do the firmware update. The firmware keeps asking that I connect via USB, which is not an option. Any thoughts on how to get past this hurdle?



I can get to the drive via Win 7 – that’s not the problem. The problem is that when I try to install the firmware, the installer says unplug all USB devices and then plug the target drive back in. This is not a USB device – it’s a network drive. I’ve put the new firmware on the drive itself and launched the update from there but still no joy – the update is demanding that I connect via USB. Do I need to go out and buy one of the USB to Ethernet cables? Is that the only way this will update? (I’ve probably thrown away several of those over the past six months during a move – can’t keep everything forever. Or maybe i should.)

I wouldn’t trust a USB-Ethernet adapter to fix the problem. It sounds to me like the installer doesn’t understand your configuration; changing that configuration might confuse it even more.

What firmware level are you running? Current levels allow updating over the SMB connection to Windows (which obviously does not require a USB connection). If it is extremely old firmware maybe there is an unusual technique for updating it. Search the web for that firmware level.

I found an old system here that was able to access the drive so I’m able to copy all my data to a more modern USB-connected drive but that still doesn’t fix the problem of the drivers. If WD can’t come up with a fix I’ll just break open the case and pull the drive – then reformat it with Win 10. The network-attached chassis will be toast but at least I’ll still have a drive.

Hey WD – do you read the comments here? Do you have a fix so I don’t have to trash the chassis?