Can't Unzip Lion Firmware Update

Hi, I’ve been following the threads about the Lion related firmware update.  I saw that there is an update to address this issue now.  So, I went to the system page on my drive, and did check for updates and it finds nothing.  So, next I tried to update manually.  I downloaded the file located at:

The problem with this approach is that I can’t unzip the file.  My mac won’t recognize it.  I tried it on a windows PC using jzip and 7zip and that did not work either.  I also tried changing it to a .iso file instead of an .img file.  When I try and open it it says that the file format is not supported and the archive cannot be opened. 

So, my question is, how the heck can I install/unzip the **bleep** update so I can get my Time Machine going again?  Any help would be much appreciated.

If you can’t unzip it they either the way it was compressed is not supported by your archive program or the download file is corrupted, I’d try again from scratch if I were you.

I, too, tried to follow that route and - initially - I tried to ‘mount’ the image as if it were a drive! The image file, though, IS the uploadable firmware, as far as I can gather. What I cannot now fathom is what is supposed to happen once ‘Submit’ has been clicked and the .img file uploaded, as the screen just reverts to the position it was in just prior to selecting the .img file on the desktop! Others have reported that an update process is started and reaches various stages (50%, 70%, etc), including complete, but mine doesn’t start doing anything at all!

Any ideas, anyone?