Can't Unmount or reformat WD Essential 2T

2T My Book Essential used for Time Machine (OS 10.9.4 Mavericks) has become corrupted.  Does not show in Finder but does show as mounted in Disk Utility, although the partition does not mount.  Am trying to reformat to make disk useable again (don’t care about the data), but both Disk Utility and WD Quick Formatter won’t format it due to “cannot unmount” error.  Also, in Activity Monitor, I see high % of CPU activity for the fsck_hfs process, which immediately goes away when drive is disconnected.

Have tried the following without success: 1) tried connecting to another Mac (also running Mavericks), 2) rebooted in Recovery Mode (same error), 3) turned off Time Machine, Spotlight and all other open programs.

Suspect that the fsck_hfs activity is keeping the drive mounted, but how do I shut that off?  Don’t have a Windows machine (perish the thought) for reformatting.  Am trying to keep this thing from becoming a $150 brick.

Any proposed solutions? 

Update on this problem.  I solved it by terminating the fsck_hfs process in Activity Monitor (click on it then hit “discontinue.”  This released the drive, and allowed it to unmount.  I was then able to reformat it using Disk Utility without a problem.  Drive is now working in Time Machine as my back-up drive.  Just saved a $150 drive from the trash!


Thank you for sharing the solution to your issue. This might be helpful to other user with the same or similar scenario.

1 Like

Clicked the star, and accepted the solution.  Over and out.