Can't unmount, drive continues running after computer turned off

Microsoft Windows 10 Home
Version 10.0.17134 Build 17134

Drive is set up with 3 partitions. The only backup software I’m running is Google Backup & Sync. Using WD Discovery and the standard Windows 10 eject function, I get error messages that the drive is in use, even after I pause Google.

As a last resort, I turn off the computer entirely and the WD external drive is still running and the white light is on. What could the drive possibly be doing if the computer is off?

If the drive is still running, is there any harm in unplugging it?

1 Like

Is your drive being indexed?


I’m not sure if the drive is in the process of being indexed if it will eject until it is completed. Try removing the indexing from the drive and see if it will eject.

1 Like

I turned off indexing in all three partitions, turned off two anti-virus programs, and quit Google Backup. The drive was then ready to unmount.

I’m not sure which of those actions made it work. Now I need to try them one-by-one.

Thanks for your help. You sent me on the right path.

Yes, there is a risk of unplugging the drive, your last write to the disk may not have actually been written to the drive, it could still be in buffers. An eject forces the buffers to be flushed and written to the drive. Once upon a time when drives were slower, a computer could be slowed drastically with every write, so the data was buffered until the CPU became idle and then written. This isn’t as big a problem now, but there is the risk of your last writes to the disk being unwritten. You can also force the buffers to be written.


I had this working a few days ago, but once again, I can’t unmount. I turned off indexing, shut down to anti-virus programs, quite Google Backup, and the device refuses to unmount. I also tried changing the policy from Quick Removal (where it was), and chose Better Performance. Of course, for this to work, I have to eject the drive before I restart the computer, which I can’t do. I’ll try anyway.

PS, I tried completely shutting down the computer. The WD drive shut down, too, but a second later, with the computer turned off, the drive started up again. This can’t possibly be the way this device is supposed to work, is it?

Update: I deleted all of the WD software that came with the Passport. The drive runs perfectly well and the eject function does what it’s supposed to do. In other words, the WD software was preventing me from ejecting the Passwort.