Can't Transfer large files via wd2go

Hi All,

I have searched the forum and this problem seems to have effected a number of people - though I havent seen any resolution, has anyone resolved this?

My set up -

mybooklive 3 TB

Web access from Windows 7 Pro (64 bit), i5, 4GB RAM

Good internet access on both sides (documented 35MBPS transfer on this set up)  

I have tried safe mode network access, couldnt connect and disabling all my security.

I’ll give a kudos to anyone who can offer a solution!

Update MBL firmware, .net framework

Enable file transfer,network discovery and sharing in windows setting

Go to dashboard Settings/network/ftp allow ftp.

Remote access is enabled

Turn firewall off

Turn antivirus off

enter in internet browser http://(drive name or ip address)/UI/ssh and enable ssh ex. http://mybooklive/UI/ssh

then transfer files!!!

if still not successful:

go to dashboard

settings/Remote access/advance rebuild wd2go server


1 Like

Thanks Trythesefirst, that’ll keep me busy!

What if you want to transfer large files from a remote location?

This is where WD2go becomes a waste for me.

2GB Transfer limit…

1 Like

so …

Does wd2go has a file transfer limit?

Can it be solved?



DanRO wrote:


Does wd2go has a file transfer limit?

Uhm, did you read the post you replied to?

i’ve read it and i’m not clarified about the limit.

the problem is that at the begining (a month a go) i’ve copied 3GB files via, and now i cannot.

I would love to see proof of people been able to copy files over 2GB  (single files) because i cannot do it and when you dig deep, the small print says you cannot copy files > 2GB.  I have found this with most NAS devices i have researched but you really have to dig to find this info.

ok pajjo,

i would like to show you, but i dont know how if i can read MBL logs with

last night i’ve copied a 3.5GB file, unfortunatelly my problems are with 4.5GB files (DVD ISOs).

why cant WD clarify this for us?

again: i’m talking about copiing files using (internet-WAN) and not local network (LAN)

It’s pretty clear in the WD 2go FAQ.

Maximum file size supported:  2GB.

If you can copy files larger than 2GB, that’s great – you’re lucky  (and so am I, because I can copy up to approx 4.2 GB) – but WD isn’t going to support it, and isn’t going to help you get there.

Here’s copying a 2.5 GB file.