Can't transfer files to MBLD (error code -50)


I can’t transfer files to my MBLD via wifi. I was already able to transfer about 200GB worth of files and it doesn’t want to transfer more files after that. An error window just pops up and says “The operation can’t be completed because an unexpected error occured (error code -50).” 

I already tried rebooting and even factory reset. The problem occurs within a day.

I’m using a Macbook pro 2011 connected to a Belkin 750DB router.

Maybe my setup is not optimal. Any suggestions on the best setup that will yield faster transfer speeds?

Any help would be appreciated. Thanks!

Have you tried from other computers? Do you have the same results? I suggest you to try bypassing your router and connect the MBLD directly to your computer, to compare results.

I keep getting this error as well. Did you figure out what it is?

I disabled the “spin down disks when not in use” checkbox in the energy saving preferences on both my Mac and in the MBLD and this seems to solve the problem.

I don’t know why it would spin down drives being activity used, but it worked.

Thanks for the replies guys!

@: I actually tried connecting it directly to my laptop but it doesn’t recognize it. Then a yellow light just keeps blinking on my MBLD

@TonyPh12345: Wow this seems like a hassle everytime I have to move files to my MBLD.

@fxguy: I’ll try your suggestion. Hopefully that solves the issue. I still can’t figure out why directly connecting my MBLD doesn’t work though.

I’m able to transfer files but I have to reduce the total size to about 1 to 2 GB per transfer which is really inconvenient. I can transfer more but I have to copy individual folder contents instead of folders. This is weird since I was able to copy huge folders before.

I get the exact same problem… Ive been transfering Large folders full of large Video Files… but now after getting about 200GB onto my ‘WD Live DUO 6TB’ it will only let me transfer over the files and not the folders themself with the files inside!?

This is very inconvenient :-/

@fxguy – Your Fix worked for me… Everybody having issues try disabling the ‘Hard Disk Sleep when not in use’ settings

Just for safety i would recomend enabling it again once your transfers are finished though…

@fxguy - I’ve tryied this fix and it’s not working for me. Similar issue it sounds like. I get an error -50 when trying to copy a folder full of images from my external LaCIe 500GB (Mac OS Extended Journaled), but I can copy a group of files instead of the folder.

Also, when I try to plug the external drive into the USB port on the MBLD, it does about 25MB per hour.  I’ve got about 130GB of pictures to upload so that’s not really going to work… seems like there’s another issue there.  Any ideas?

I have same issue. Am now trying to back it up via time machine then extract it as my main database. I hope it works.
has anyone tried using the disk utility to copy? Any luck/suggestions?