Can't transfer data onto hdd

hello, ive tried searhing the forums for answers but to no luck!

I bought a 1tb my passport for Mac last year. I transferred my old data from my old Macbook onto this hdd with no issues. Recently I went to use my hdd again to transfer my work off my new macbook air (2017 model). Once I double clicked on the hdd there was no files that I had transferred, only the original files you find on the hdd when you first get it. So I tried to transfer my data onto the hdd and it wouldn’t transfer, just kept coming up with a ‘no entry’ sign on the pointer, no error messages or anything. I’ve tried on other computers but to no luck. This hdd hasn’t been dropped or anything, so not sure whats going on. I’ve checked the settings and nothing seems to have been tampered with

Thanks in advance

So i’ve googled the solution, the hdd is set to Read only. Not sure whats happened to my other files on the hdd. but if I format this hdd and change the settings it can be used cross compatible with pc and Mac. Any other tips welcome