Can't sync via WD Sync from WAN

Hello,

Do you have SSL enabled as a WD Sync option?

If you login to MyCloud.com from the Windows 10 WAN PC, can you access your EX2 Ultra or does it show as “offline” ?

  1. Yes I’ve tried with SSL - this didn’t helped (but it’s said on my local network, why should I enable this on WAN Internet?)
  2. Shows online and I’m able to access it

Any more questions?

I can tell more - I can connect with My WD Cloud for Windows app, everything working, but not with WD Sync app.

So, can I receive some official WD Support here?

The WD Community is a forum for Users. While WD personnel may occasionally address some topics, please bear in mind WD has direct support channels meant to provide direct assistance.

It would be best to describe in detail the issues you are experiencing while contacting WD Support. They may contact you if additional information is needed, but details like such as the router you use (And router firmware), your Internet Service Provider, network layout (Wireless – g/b/n/ac / Wired, Switches, Hubs, Cable types), how many devices and Operating System will greatly help isolating the root of the issue.

WD Support Case #[Deleted-Privacy] opened 2 days ago and still no answer.

I have exactly the same problem with my EX2 Ultra. WD Sync cant find my device, if the computer is not in same network. Access through mycloud.com is possible.

Interessting: After i connected my laptop once in the same network with the NAS, WD Sync is working also from other networks.

That’s good, but how I suppose to do this if I can’t bring second computer to my LAN?

same problem with my desktop computer… Perhaps connecting via VPN will work, but thats not the way it shoud be :confused:

Do you solve the problem?

I have exactly the same problem, the access with the mobile aplication or web is fine but the problem is with WD Sync, and After i connected my laptop once in the same network with the NAS, WD Sync is working also from other networks.

any idea to fix it ??

I have same problem.

Anybody can solve it?

WD My Cloud Ex2 Ultra designated apps are tortureware, and WD is lying about its capabilities.
I absolutely hate this product, and it’s been just one month from buying date.
I hoped for private cloud for family and friends (dropbox like) and it’s nothing like that.

Anyways, I’m stuck with same problem as OP.
Following WD Sync Online User Guide and Solutions at https://support.wdc.com/knowledgebase/answer.aspx?ID=19492
KB ID
Configuration 13178 Configuring WD Sync for use over the Internet
This is pure rubbish as SSL enabling has nothing to do with device discovery process.
I ran wireshark and sysinternal’s process explorer to collect network activity of tortureware WDSyncUI.exe.
It is sending multicast to 239.255.255.250 over UDP/1900 - SSDP
https://wiki.wireshark.org/SSDP

Good job WD, mine and family home routers surely support multicast routing, not to mention ISP’s support.
Please fix this tortureware and delete the garbage KB ID 13178.

After i had a ticket with WD for a month and no solution, i fixed it myself.
DISCLAIMER: This works with WD Sync Version 1.3.5949 AS OF 21.09.2017 AND MIGHT NOT WORK IN THE FUTURE.
Quick fix for non-programmers: (what i did is below)

  1. Quit WD Sync
  2. Go to folder "C:\Program Files (x86)\Western Digital\WD App Manager\Plugins\WD Sync\App\Devices\".
  3. Rename WDMyClouds.dll to WDMyClouds_.dll
  4. Download https://www.dropbox.com/s/ldr1kth237cjse5/WDMyClouds.dll?dl=0 and put it into the folder.
  5. Right-Click the file, go to Properties, and only if it says “This file is from a different computer and was blocked for safety” check “Unblock”, if it gives you an error, press Retry and then confirm.
  6. Start WD Sync, find your EX2Ultra after logging into mycloud!
  7. (Optional) AFTER you got WD Sync to work, quit it again. Delete the downloaded WDMyClouds.dll and rename WDMyClouds_.dll back to WDMyClouds.dll, then start WD Sync again. The file is only used for discovery, once you are “paired” it will continue to work.

Explanation:
The fix is simple, and it is a programming error from WD in the WD Sync software. (Use any IL-Editor of your choice).
In "C:\Program Files (x86)\Western Digital\WD App Manager\Plugins\WD Sync\App\Devices\WDMyClouds.dll" you need to change the OrionModelNumber ExportMetadataAttribute of class DEV_0314 to read this:
[ExportMetadata("OrionModelNumber", "MY_CLOUD_EX2_ULTRA")].
Thats all. Recompile, Restart WD Sync and you are good.

Greetings all!

3 Likes

@ Nefarion
It Works Man!!!

Thank You Very Much!!!

Western Digital Learn Something with this!!!

OMG THIS WORKS. THANK YOU THANK YOU.

If someone from WD is reading this. Please fix this

@ Nefarion you are the bomb

Nefarion, thank you Sir!
This fixed the problem, amazing job done!

Just spent two days trying to get this to work and this is a lifesaver (worried it hadn’t worked but then remembered to check “unblock” in the file properties - remember this stage!).

Awesome job Nefarion - thanks so much for sharing your work.

It works , but

wait , after I tried your solution , I cannot access my cloud anymore through my online account or my WD Access app , I can access the storage however , hope that it was not because of your solution

WD wasted my few nights’ time to troubleshoot with no result.
You are really good!