Can't stream movie to Apple TV

I purchased the 4 TB My Cloud about 6 months ago and everything worked great. I have about 200 movies on the drive and have had no problems using the app on my iPhone or iPad and streaming movies. Once the movie starts to stream, I have been able to use AirPlay to stream to my Apple TV with no trouble. A few weeks ago, this changed. I am still able to stream movies on any of the devices, but when I select the AirPlay icon on the iPhone or iPad, it switches over to my tv, but the movie won’t play, it just continues to what appears to be buffering and doesn’t stop. Once I deselect the AirPlay icon, the movie goes back to playing on my device just fine. It’s not Apple TV or the phone because I am able to go to Netflix and Amazon Instant Videos and play them using AirPlay to the Apple TV with no problem. It is specific to the WD App that is not letting it go from the device to the Apple TV. I have tried everything including updating all software and rebooting everything. Any suggestions?

Have you tried pressing the reset button on the back of the My Cloud?