Can't sign into wdmycloud after firmware update

can’t sign into wdmycloud after firmware update. It’s not visible in Win10 File, and when I run the WDcloud app I can’t enter my login info because I can’t enter info in the name box. Also can’t upload from iPhone OneDrive app. All worked OK until I did the drive update.


What kind of issue are you facing? please, describe in details showbox.

Opened mycloud app(win10)
did firmwear update
can’t enter login name in box
mycloud also not visible in “this PC”

What “mycloud app” are you using on Windows 10? The My Cloud Dashboard using a web browser? Or the My Cloud Desktop program/software for Windows?

The My Cloud Desktop program has been End of Life since 2016. Recent firmware updates render the My Cloud Desktop program unusable as it will no longer let one log into their My Cloud. For local network access one does not need to use the My Cloud Desktop program, one can use Windows File Explorer or Mac Finder. The WD Knowledgebase article on the WD My Cloud Desktop program no longer supported.

My Cloud Desktop App No Longer Works with a My Cloud or Login Not Authorized

Certain Microsoft updates to Windows 10 will disable SMB1 which will cause Windows File Explorer to not see the My Cloud under Network.

How to Enable SMB 1.0/CIFS File Sharing Support on Windows 10

Thanks, looks like all working again.
Maybe I should of “if it’s not broken don’t try and fix it”?