Can't sign in

Hi. I’m having an issue. I’ve recently upgraded to OS 5. I downloaded the new app for iOS and things were fine. Until they weren’t. I restarted my device and it signed me out of my cloud account in the dashboard. I can’t seem to sign back in on the dashboard. I’m presented with this error:

Error: Something went wrong, please check that you have an active internet connection and try again. Invalid state.

I have an active internet connection. I’ve changed my password multiple times. But whatever I do, it doesn’t want to allow me to signin. Despite the account working fine on mobile. I’m all out of ideas. Does anyone know how to resolve this?


1 Like

I have this on all 3 devices today…this is terribly frustrating and WD support is not doing anything to resolve this. I can’t even create a new account without getting that message.

It’s really annoying. I’ve restarted it multiple times, changed passwords multiple times. There aren’t many options to try. I’m considering reinstalling the firmware but I’m afraid something would go wrong and I’ll lose all of my data.

1 Like

I think WD should have live support. This is clearly affecting a LOT of us. Even that stupid 40 second reset doesn’t fix it. I think the issue must be on their side …I can’t even create a NEW cloud account now…I get that same stupid message… so… seems like their problem to me.

What’s the 40 sec reset?

I found a solution. I simply switched my ethernet cord. I’m not sure why that worked, but when I switched it and tried again it immediately worked. Remove the ethernet cord and wait for the email notification confirming its lost connection, then plug it back in (or switch it like I did). Boom - able to sign in with no issues.

1 Like

Thanks for sharing :slight_smile: I was out when I received this update. When I got home the problem went away on all of my devices… I didn’t do a thing … just logged in and boom, it was fixed. I planned on trying your solution but wanted to see if the problem was still there before I tried it. I was stunned when it just worked without doing a thing. I really have to wonder and think the issue was on the WD side.

The 40 second reset removes all users and resets the device to factory defaults, but it doesn’t remove any of your data.
It’s the second thing that WD always suggests and it’s a pain because even though your data is fine, you need to add back the users and re-invite the users again. It’s not horrible but the people in my family get pretty annoyed about it…and I do too.

The process is :
Power off device
Push the reset button and while holding plug the device back in–keeping the reset button pushed for 40 seconds
Then release the reset button and the device will boot and after a few minutes it’s back to factory defaults—the only thing ‘not’ gone is your data. So… your device name, IP address, network config and just about everything else is set back to normal.

Here is a link to it on the WD site:
Option B: 40 Second Reset (Reset with Power Off)


Option B: 40 Second Reset (Reset with Power Off)

Hi, I don’t recall setting an administrator account during the initial set up of My Cloud, therefore I need to r…

](Option B: 40 Second Reset (Reset with Power Off))

Whoa thats really weird. I wonder what the issue really is. There’s obviously issues because so many people are having this problem. Maybe they should add “wait and see” to the official knowledge base :laughing:

I actually didn’t consider the 40 second reset. Forgot all about it. Thanks for the reminder. If this thing decides to rebel again I’ll keep that tool in the toolbox. Thanks!!!

LOL you made me truly laugh with the ‘wait and see’ knowledgebase idea. :slight_smile:

Great talking with you… it helps to know I’m not alone when I’m pounding my head on the wall.

tx again!

1 Like