Can't set-up password for new user on mycloud.com

Hi.
I just added a new user to our DL4100, and the link she received in her e-mail to configure a password opens up a blank page. Any ideas are much appreciated!

See attached screenshots for reference.

Does this happen when using a different Internet browser?

yes. Tried it on 2 machines with Chrome and Safari each.
I was able to find a work-around by going to the main mycloud.com sign-in, and selecting the Forgot Password route. That e-mailed link worked. Still scratching my head though on why the main link still isn’t working.

Thanks!

1 Like

Same problem here. Will be calling WD support on Monday. It was rather embarrassing when I expected my father to create a password for his new account yet he gets same blank page as Olaf_Richter. I tried doing it on Chrome, Firefox and Edge

I’ve got the same problem. Has someone found a fix for this issue?

Hi, I have exactly the same issue as well - so did anybody find a solution in the end?
Thanks

I have the same problem with adding new users…

any advice?

Look at the work-around I posted above.