Can't set up My Book Live 2TB


     I recieved my My Book Live today along with my new switch and i cant seeme to get them to work, the cd it came with wont pick up the NAS, however i can manage settings through the web UI, 

Error i get on the CD is as follows

Then i tried to the WD link software to see if that will pick it up and it does however i can not map the drive, ( I presume this means giving the drive a letter so it shows in my computer ) 

After this i attempted to use the web interface to manage my files but clicking on view my files just takes me to my documents ( Local ) 

finally i tried the twonky media address, i can add files to the my book live through here but not remove or play back, i was just wondering if this is all correct becuase if it is im sending this back to amazon as its horrid. 

Cheers for any help provided :D 

Greggars… I assume that the My Book is attached to the Switch. What is the Switch attached to?  My setup was through the Web UI and I had no problems… cj

I have tried it on both my 

cisco linksys switch and direct from my Virgin Media Superhub (UK)