Can't see some .mkv files or some other files on WDLive but can see on PC


#1

I can see and play all my movies (.avi, .mkv, etc) on my PC but can’t see some of the movies (.mkv) with the WDLive.

I can see them in file management but not in movies to play them. I even tried renaming them but can’t see them with WDLive.

They do play with Media Player in windows though.


#2

How are you connecting?  Net shares or media player?  And wired or wireless?


#3

Connecting media player and wired.

Tried netshares and same thing.

only time I can see the file I want is in file management.

Tried renaming file and shorten the file name and moving it out of the folder (which also cannot be seen) and still can’t see it.


#4

Let’s stick with net shares.

In your shared directory, do you see other video files?  IOW, put three files in a directory, including one that you can’t see, and tell me if you can see the other two.  If so, can you provide the full details of that file here?  (Use mediainfo).


#5

Ok, I’ll try that,
but I did move it out of the unseen folder to the root of the “movies” folder and it does not show in WD as well as a few other files that I can see with PC but not in WD.

All  unseen files ar seen on PC and play on the PC.

I just wonder… some file were downloaded using a Linux Ubuntu pc and then copied over to the media server.

Now not sure which but I wonder if that is it, but a file is a file in the media that is downloaded. And they work on a PC including my “Vista” pc…


#6

I’m having a similar problem. I have 2 WDLive and both of them are only showing ~1425 of my 1620 MP4 files encoded with Handbrake when connecting through Media Servers. 1 WDLive is wired and the other is wireless.


#7

Can’t speak for your problem, but for the OP it might be a filename issue (since those files were created on Linix).  I’d make sure the names were completely vanilla (no odd characters, and actually I’d even try renaming them so they were VERY plain, like one.mkv, two.mkv, etc.)


#8

As I mentioned previously above, I have renamed the file as simple as possible. I also checked the file attributes and they appear to be the same as the other files which present no problems. Nothing makes a difference.

I wonder if I can convert the file to, but convert to what?

Maybe I should try to copy the file to my PC and delete off media server and then copy back to it. Seems like a strange thing to do but it might work.


#9

Here are my results of this experiment.

I copied the .mkv file to my PC and deleted it from the NAS media server.

I renamed the file by adding _ between the 3 words.

I copied this file back to the NAS Media server.

Tried to view and play the file with the WDLive was successful.

In conclusion for all with the same problem:

Copy the unseen file to your PC .

Delete the same file from your media server.

Rename the file on your PC.

Copy back this renamed file back to the Media Server so the WDLive can see it and play it.


#10

I jus may have discovered another reason for missing files in media server viewing.

You may need to “Refresh” UPnP Server settings  after adding new media.

Doing that right now, however it is slow, will check later to see if that allows the other missing files tbe seen.