Can't see EX2 in File Explorer

I have 3 windows 10 Pro PC’s.
My Ex2 is connected to my router.
I can see the EX2 on one PC but not on the other two.

My EX2 is visible in File Explorer(network section) on my Surface Pro 4.

On the other two PC’s (Dell XPS desktop and HP Laptop)

  • My EX2 is NOT visible in file explorer/network section
  • The EX2 dashboard is visible

How can I make my EX2 visible in File Explorer network section of all of my PC’s?

I found that when I restarted one of my computers is when the EX2 showed up properly in the Network explorer as a SMB share (must of forced a rescan).
With share identification/reporting, there is usually one device on the network that takes this responsibility to report to all the other devices what devices are on the network, but if this device restarts/goes offline, then another device may pick up the responsibility.
I have found that sometimes these master browsers don’t perform their job as well as others.

Thankfully WD as implemented the ability for the EX2 to become the designated “Local Master Browser”.
Turn this on in the Network settings of the device.

This is a great idea of WD as the EX2 should be a device that is on 24/7 365 and it does a great job of the Local Master Browser (shares show up faster and consistently lists an accurate list of devices on the network).

Thanks for your suggestion.
I tried it but I still cannot see the EX2 in the File Explorer.

start a windows command prompt and type
net view
(of course then press enter)

what shares are reported?

When I run net view as an administrator I get the message “the service has not been started”
(HP laptop ad Dell Desktop)

When I run net view on my Surface Pro (the PC from which I can access the EX2)
I get three result lines:
One for the HP, one for the Dell Desktop and one for the Ex2.

That information you provided was very informative.

It seems that Windows 10 has known problems with viewing shares and MASTER BROWSER; some users have reported fixes while other users have states the fixes don’t work.
Microsoft needs to issue a full fix.

You can read what I read and see if any of the user fixes works for you. Also watch these threads as it may relay an official Microsoft fix (none so far).

another good read

Thanks, I read the links … whew!
The following information may help:

Each of my 3 PC’s are running Windows 10.0.16299 build 16299.
Only one PC runs net view and can access the WD EX2

I suspect that this may be related to the Master Browser assignment.
I tried to find out which PC is the master browser but could not find an explanation that worked for me.
Any suggestions?

…more tests:
Procedure: Start each of my 3 PC’s with the other two shut down.
1: net view runs correctly on each PC when it is the only PC on the network.
2: I can access the shares on my WD Ex2 from my Dell XPS 8700 desktop when it is the only PC that is running.

So it seems that the first PC that is started is allowed to have access to the WD EX2 on the network. (probably because the network assigns the master browser role to the first PC to start.)

So to paraphrase what you and others have said in the threads that you linked:
“Microsoft has a bug in their Windows 10 network software that seems to have been there for at least six months.”

I just attached the MyCloud EX2 Ultra to my router (renamed it MyCloud). There’s a MyBookLive NAS drive also on the router - it appears in Explorer/Network but the MyCloud does not (on any of 3 Win10 computers). I have not installed any software yet except an Android app and am wondering if one of the WD programs is needed for my network to see it. Any help appreciated

Today MyCloud appeared in Explorer’s This PC in the right pane under Network locations as type “Media Server”. (Still not in Network left pane with MyBookLive).

If I type \MyCloud in Explorer address bar, it (temporarily) appears under Network left pane and in the right pane under Media Devices. Both drives are under Storage. MyBookLive is in the right pane under Computer and Storage (both have “Shared Music”).

I mapped the drive by typing as the popup doesn’t see it. I ran a batch script that writes to it. My Android WD app can access it. Only Windows doesn’t see it.

You are not alone!
More at this thread - especially the links.

The consensus seems to be that these types of problem are caused by a bug in Windows 10.

1 Like

It’s 4 years later and same problem with two Mycloud EX2 Ultras. I had them both showing in Explorer yesterday after power cycling and managed to transfer a lot of files to the new one. Today neither is listed under Network. I got the older one to show by using a shortcut but it’s not showing in a new Explorer window. The new drive is gone. Madly looking for notes how I fixed it last time.

If this is OS/3 (not the new OS/5). . . .this was never resolved. Most annoying.

I just memorized the IP and device name, and “address” the drive directly from the address bar when I want to see files.

I use shortcuts for \\MyCloud and \\MyCloud4 to open the drives in File Explorer. But when the second drive was not accessible, only power cycling made it connect. I found and tried a list of things that didn’t really solve the issue:

  1. enable “SMB 1.0/CIFS File Sharing Support”
  2. Enable Netbios Over TCP/IP (was already set)
  3. Change Network Connection to Private (was already private)
  4. Enable Network Discovery & File Sharing for Private Network (already set)
  5. Disable SMB 2.0 & 3.0 (didn’t do this)

Another suggestion to create a static IP in the Mycloud dashboard had the unfortunate result of listing two drives called Mycloud! I reversed that setting and instead reserved IP addresses for the drives in the Internet Modem dashboard So far it seems to be working.